summaryrefslogtreecommitdiffstats
path: root/av7110/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 08:09:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 08:09:22 +0000
commit6b4d032d4964caaa85be4ba8f3a7874afbf958cc (patch)
treea9846103274b39705a7e8be9fc28c006c18094b1 /av7110/Makefile
parentInitial commit. (diff)
downloadfirmware-nonfree-6b4d032d4964caaa85be4ba8f3a7874afbf958cc.tar.xz
firmware-nonfree-6b4d032d4964caaa85be4ba8f3a7874afbf958cc.zip
Adding upstream version 20230625.upstream/20230625
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'av7110/Makefile')
-rw-r--r--av7110/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/av7110/Makefile b/av7110/Makefile
new file mode 100644
index 0000000..a2776fe
--- /dev/null
+++ b/av7110/Makefile
@@ -0,0 +1,11 @@
+CC = arm-linux-gnueabi-gcc
+LD = arm-linux-gnueabi-ld
+OBJCOPY = arm-linux-gnueabi-objcopy
+
+bootcode.bin: Boot.S
+ $(CC) -mbig-endian -c Boot.S
+ $(LD) -Ttext 0x2c000000 -EB -o Boot Boot.o
+ $(OBJCOPY) -Obinary Boot bootcode.bin
+
+clean:
+ rm -f Boot.o Boot bootcode.bin