summaryrefslogtreecommitdiffstats
path: root/microbench/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'microbench/CMakeLists.txt')
-rw-r--r--microbench/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/microbench/CMakeLists.txt b/microbench/CMakeLists.txt
new file mode 100644
index 0000000..639915b
--- /dev/null
+++ b/microbench/CMakeLists.txt
@@ -0,0 +1,17 @@
+if(MSVC)
+ return()
+endif()
+
+set(CMAKE_REQUIRED_LIBRARIES rt)
+check_function_exists(clock_gettime HAVE_CLOCK_GETTIME)
+
+if(APPLE)
+ add_definitions(-DFLAC__SYS_DARWIN)
+endif()
+
+add_executable(benchmark_residual benchmark_residual.c util.c)
+target_include_directories(benchmark_residual PRIVATE
+ "$<TARGET_PROPERTY:FLAC,SOURCE_DIR>/include")
+target_link_libraries(benchmark_residual
+ FLAC
+ $<$<BOOL:${HAVE_CLOCK_GETTIME}>:rt>)