summaryrefslogtreecommitdiffstats
path: root/src/test_libs_common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/test_libs_common/Makefile.am')
-rw-r--r--src/test_libs_common/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/test_libs_common/Makefile.am b/src/test_libs_common/Makefile.am
new file mode 100644
index 0000000..30e1f15
--- /dev/null
+++ b/src/test_libs_common/Makefile.am
@@ -0,0 +1,29 @@
+# test_libs_common - Common code to library unit tests
+# Copyright (C) 2000-2009 Josh Coalson
+# Copyright (C) 2011-2023 Xiph.Org Foundation
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+AM_CPPFLAGS = -I$(top_builddir) -I$(srcdir)/include -I$(top_srcdir)/include
+
+noinst_LTLIBRARIES = libtest_libs_common.la
+
+libtest_libs_common_la_SOURCES = \
+ file_utils_flac.c \
+ metadata_utils.c
+
+EXTRA_DIST = \
+ CMakeLists.txt \
+ README