summaryrefslogtreecommitdiffstats
path: root/src/test_seeking/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/test_seeking/Makefile.am')
-rw-r--r--src/test_seeking/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/test_seeking/Makefile.am b/src/test_seeking/Makefile.am
new file mode 100644
index 0000000..9c9b8da
--- /dev/null
+++ b/src/test_seeking/Makefile.am
@@ -0,0 +1,39 @@
+# test_seeking - Seeking tester for libFLAC
+# Copyright (C) 2004-2009 Josh Coalson
+# Copyright (C) 2011-2023 Xiph.Org Foundation
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+EXTRA_DIST = \
+ CMakeLists.txt
+
+AM_CFLAGS = @OGG_CFLAGS@
+
+AM_CPPFLAGS = -I$(top_builddir) -I$(srcdir)/include -I$(top_srcdir)/include
+
+check_PROGRAMS = test_seeking
+
+if OS_IS_WINDOWS
+win_utf8_lib = $(top_builddir)/src/share/win_utf8_io/libwin_utf8_io.la
+endif
+
+test_seeking_LDADD = \
+ $(top_builddir)/src/libFLAC/libFLAC.la \
+ $(win_utf8_lib)
+
+test_seeking_SOURCES = \
+ main.c
+
+CLEANFILES = test_seeking.exe