summaryrefslogtreecommitdiffstats
path: root/scripts/crossbuild/docker/centos8
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-26 10:41:53 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-26 10:41:53 +0000
commit1526b335a5a81d945e64291e2fbcf92f72d15a4e (patch)
tree64d3bc5d36df06664cc49d7c4d8710100e23b888 /scripts/crossbuild/docker/centos8
parentReleasing progress-linux version 3.2.3+dfsg-2~progress7.99u1. (diff)
downloadfreeradius-1526b335a5a81d945e64291e2fbcf92f72d15a4e.tar.xz
freeradius-1526b335a5a81d945e64291e2fbcf92f72d15a4e.zip
Merging upstream version 3.2.5+dfsg.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripts/crossbuild/docker/centos8')
-rw-r--r--scripts/crossbuild/docker/centos8/Dockerfile81
1 files changed, 0 insertions, 81 deletions
diff --git a/scripts/crossbuild/docker/centos8/Dockerfile b/scripts/crossbuild/docker/centos8/Dockerfile
deleted file mode 100644
index bd856af..0000000
--- a/scripts/crossbuild/docker/centos8/Dockerfile
+++ /dev/null
@@ -1,81 +0,0 @@
-FROM centos:centos8
-
-#
-# Install devtools like make and git and the EPEL
-# repository for freetds and hiredis
-#
-RUN yum update -y
-RUN yum install -y rpmdevtools openssl epel-release git yum-utils rsync dnf-plugins-core
-RUN dnf config-manager --set-enabled powertools
-
-#
-# Install GCC that has the requisite support for C11 keywords and atomics
-#
-RUN yum install -y gcc-toolset-9
-
-#
-# Documentation build dependecies
-#
-# - doxygen & JSON.pm
-RUN yum install -y doxygen graphviz perl-JSON
-# - antora (npm needed)
-RUN curl -sL https://rpm.nodesource.com/setup_10.x | bash -
-RUN yum install -y nodejs
-RUN npm i -g @antora/cli@2.1 @antora/site-generator-default@2.1
-# - pandoc
-RUN curl -o - -L $(curl -s https://api.github.com/repos/jgm/pandoc/releases/latest | grep "browser_download_url.*tar.gz" | cut -d '"' -f 4) | tar xzvf - -C /tmp/
-RUN mv /tmp/pandoc-*/bin/* /usr/local/bin
-# - asciidoctor
-RUN yum install -y rubygems-devel
-RUN gem install asciidoctor
-
-#
-# Setup a src dir in /usr/local
-#
-RUN mkdir -p /usr/local/src/repositories
-WORKDIR /usr/local/src/repositories
-
-#
-# Use LTB's openldap packages intead of the distribution version to avoid linking against NSS
-#
-RUN echo $'[ltb-project]\n\
-name=LTB project packages\n\
-baseurl=https://ltb-project.org/rpm/$releasever/$basearch\n\
-enabled=1\n\
-gpgcheck=1\n\
-gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-LTB-project'\
-> /etc/yum.repos.d/ltb-project.repo
-RUN rpm --import https://ltb-project.org/lib/RPM-GPG-KEY-LTB-project
-
-#
-# Shallow clone the FreeRADIUS source
-#
-WORKDIR /usr/local/src/repositories
-ARG source=https://github.com/FreeRADIUS/freeradius-server.git
-RUN git clone --depth 1 --no-single-branch ${source}
-
-#
-# Install build dependencies for all branches from v3 onwards
-#
-WORKDIR freeradius-server
-RUN for i in $(git for-each-ref --format='%(refname:short)' refs/remotes/origin 2>/dev/null | sed -e 's#origin/##' | egrep "^(v[3-9]*\.[0-9x]*\.x|master)$");\
- do \
- git checkout $i; \
- [ -e redhat/freeradius.spec ] && yum-builddep -y redhat/freeradius.spec; \
- done
-
-#
-# Which is required by fixture setup utilities
-#
-RUN yum install -y which
-
-#
-# Explicitly install libnl3-devel which is required for the EAP tests
-#
-RUN yum install -y libnl3-devel
-
-#
-# Create the RPM build tree
-#
-ENV BUILDDIR=/root/rpmbuild
-RUN rpmdev-setuptree