summaryrefslogtreecommitdiffstats
path: root/uwac/templates
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 01:24:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 01:24:41 +0000
commita9bcc81f821d7c66f623779fa5147e728eb3c388 (patch)
tree98676963bcdd537ae5908a067a8eb110b93486a6 /uwac/templates
parentInitial commit. (diff)
downloadfreerdp3-a9bcc81f821d7c66f623779fa5147e728eb3c388.tar.xz
freerdp3-a9bcc81f821d7c66f623779fa5147e728eb3c388.zip
Adding upstream version 3.3.0+dfsg1.upstream/3.3.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'uwac/templates')
-rw-r--r--uwac/templates/CMakeLists.txt47
-rw-r--r--uwac/templates/build-config.h.in22
-rw-r--r--uwac/templates/buildflags.h.in11
-rw-r--r--uwac/templates/config.h.in11
-rw-r--r--uwac/templates/uwac.pc.in15
-rw-r--r--uwac/templates/uwacConfig.cmake.in9
-rw-r--r--uwac/templates/version.h.in32
7 files changed, 147 insertions, 0 deletions
diff --git a/uwac/templates/CMakeLists.txt b/uwac/templates/CMakeLists.txt
new file mode 100644
index 0000000..14dfc68
--- /dev/null
+++ b/uwac/templates/CMakeLists.txt
@@ -0,0 +1,47 @@
+set(UWAC_INCLUDE_DIR "include/uwac${UWAC_VERSION_MAJOR}")
+
+if (NOT UWAC_FORCE_STATIC_BUILD)
+ # cmake package
+ export(PACKAGE uwac)
+
+ SetFreeRDPCMakeInstallDir(UWAC_CMAKE_INSTALL_DIR "uwac${UWAC_VERSION_MAJOR}")
+
+ configure_package_config_file(
+ ${CMAKE_CURRENT_SOURCE_DIR}/uwacConfig.cmake.in
+ ${CMAKE_CURRENT_BINARY_DIR}/uwacConfig.cmake
+ INSTALL_DESTINATION ${UWAC_CMAKE_INSTALL_DIR}
+ PATH_VARS UWAC_INCLUDE_DIR)
+
+ write_basic_package_version_file(
+ ${CMAKE_CURRENT_BINARY_DIR}/uwacConfigVersion.cmake
+ VERSION ${UWAC_VERSION}
+ COMPATIBILITY SameMajorVersion)
+
+ install(FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/uwacConfig.cmake
+ ${CMAKE_CURRENT_BINARY_DIR}/uwacConfigVersion.cmake
+ DESTINATION ${UWAC_CMAKE_INSTALL_DIR})
+
+ install(EXPORT uwac DESTINATION ${UWAC_CMAKE_INSTALL_DIR})
+endif()
+
+set(UWAC_BUILD_CONFIG_LIST "")
+GET_CMAKE_PROPERTY(res VARIABLES)
+FOREACH(var ${res})
+ IF (var MATCHES "^WITH_*|^BUILD_TESTING|^UWAC_HAVE_*")
+ LIST(APPEND UWAC_BUILD_CONFIG_LIST "${var}=${${var}}")
+ ENDIF()
+ENDFOREACH()
+string(REPLACE ";" " " UWAC_BUILD_CONFIG "${UWAC_BUILD_CONFIG_LIST}")
+configure_file(version.h.in ${CMAKE_CURRENT_BINARY_DIR}/../include/uwac/version.h)
+configure_file(buildflags.h.in ${CMAKE_CURRENT_BINARY_DIR}/../include/uwac/buildflags.h)
+configure_file(build-config.h.in ${CMAKE_CURRENT_BINARY_DIR}/../include/uwac/build-config.h)
+configure_file(config.h.in ${CMAKE_CURRENT_BINARY_DIR}/../include/uwac/config.h)
+
+if (NOT UWAC_FORCE_STATIC_BUILD)
+ include(pkg-config-install-prefix)
+ configure_file(uwac.pc.in ${CMAKE_CURRENT_BINARY_DIR}/uwac${UWAC_VERSION_MAJOR}.pc @ONLY)
+
+ set(UWAC_INSTALL_INCLUDE_DIR ${UWAC_INCLUDE_DIR}/uwac)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/uwac${UWAC_VERSION_MAJOR}.pc DESTINATION ${PKG_CONFIG_PC_INSTALL_DIR})
+endif()
diff --git a/uwac/templates/build-config.h.in b/uwac/templates/build-config.h.in
new file mode 100644
index 0000000..a2c103e
--- /dev/null
+++ b/uwac/templates/build-config.h.in
@@ -0,0 +1,22 @@
+#ifndef UWAC_BUILD_CONFIG_H
+#define UWAC_BUILD_CONFIG_H
+
+#define UWAC_DATA_PATH "${WINPR_DATA_PATH}"
+#define UWAC_KEYMAP_PATH "${WINPR_KEYMAP_PATH}"
+#define UWAC_PLUGIN_PATH "${WINPR_PLUGIN_PATH}"
+
+#define UWAC_INSTALL_PREFIX "${WINPR_INSTALL_PREFIX}"
+
+#define UWAC_LIBRARY_PATH "${WINPR_LIBRARY_PATH}"
+
+#define UWAC_ADDIN_PATH "${WINPR_ADDIN_PATH}"
+
+#define UWAC_SHARED_LIBRARY_SUFFIX "${CMAKE_SHARED_LIBRARY_SUFFIX}"
+#define UWAC_SHARED_LIBRARY_PREFIX "${CMAKE_SHARED_LIBRARY_PREFIX}"
+
+#define UWAC_VENDOR_STRING "${VENDOR}"
+#define UWAC_PRODUCT_STRING "${PRODUCT}"
+
+#define UWAC_PROXY_PLUGINDIR "${WINPR_PROXY_PLUGINDIR}"
+
+#endif /* UWAC_BUILD_CONFIG_H */
diff --git a/uwac/templates/buildflags.h.in b/uwac/templates/buildflags.h.in
new file mode 100644
index 0000000..d16dfb9
--- /dev/null
+++ b/uwac/templates/buildflags.h.in
@@ -0,0 +1,11 @@
+#ifndef UWAC_BUILD_FLAGS_H
+#define UWAC_BUILD_FLAGS_H
+
+#define UWAC_CFLAGS "${CMAKE_C_FLAGS}"
+#define UWAC_COMPILER_ID "${CMAKE_C_COMPILER_ID}"
+#define UWAC_COMPILER_VERSION "${CMAKE_C_COMPILER_VERSION}"
+#define UWAC_TARGET_ARCH "${TARGET_ARCH}"
+#define UWAC_BUILD_CONFIG "${UWAC_BUILD_CONFIG}"
+#define UWAC_BUILD_TYPE "${CMAKE_BUILD_TYPE}"
+
+#endif /* UWAC_BUILD_FLAGS_H */
diff --git a/uwac/templates/config.h.in b/uwac/templates/config.h.in
new file mode 100644
index 0000000..90caf39
--- /dev/null
+++ b/uwac/templates/config.h.in
@@ -0,0 +1,11 @@
+#ifndef UWAC_CONFIG_H
+#define UWAC_CONFIG_H
+
+/* Include files */
+#cmakedefine UWAC_HAVE_TM_GMTOFF
+#cmakedefine UWAC_HAVE_POLL_H
+#cmakedefine UWAC_HAVE_SYSLOG_H
+#cmakedefine UWAC_HAVE_JOURNALD_H
+#cmakedefine UWAC_HAVE_PIXMAN_REGION
+
+#endif /* UWAC_CONFIG_H */
diff --git a/uwac/templates/uwac.pc.in b/uwac/templates/uwac.pc.in
new file mode 100644
index 0000000..c0abdee
--- /dev/null
+++ b/uwac/templates/uwac.pc.in
@@ -0,0 +1,15 @@
+prefix=@PKG_CONFIG_INSTALL_PREFIX@
+exec_prefix=${prefix}
+libdir=${prefix}/@CMAKE_INSTALL_LIBDIR@
+includedir=${prefix}/@UWAC_INCLUDE_DIR@
+libs=-luwac@UWAC_VERSION_MAJOR@
+
+Name: uwac@UWAC_API_VERSION@
+Description: uwac: using wayland as a client
+URL: http://www.freerdp.com/
+Version: @UWAC_VERSION@
+Requires:
+Requires.private: wayland-client xkbcommon freerdp@FREERDP_VERSION_MAJOR@
+Libs: -L${libdir} ${libs}
+Libs.private:
+Cflags: -I${includedir}
diff --git a/uwac/templates/uwacConfig.cmake.in b/uwac/templates/uwacConfig.cmake.in
new file mode 100644
index 0000000..2433842
--- /dev/null
+++ b/uwac/templates/uwacConfig.cmake.in
@@ -0,0 +1,9 @@
+@PACKAGE_INIT@
+
+set(UWAC_VERSION_MAJOR "@UWAC_VERSION_MAJOR@")
+set(UWAC_VERSION_MINOR "@UWAC_VERSION_MINOR@")
+set(UWAC_VERSION_REVISION "@UWAC_VERSION_REVISION@")
+
+set_and_check(UWAC_INCLUDE_DIR "@PACKAGE_UWAC_INCLUDE_DIR@")
+
+include("${CMAKE_CURRENT_LIST_DIR}/uwac.cmake")
diff --git a/uwac/templates/version.h.in b/uwac/templates/version.h.in
new file mode 100644
index 0000000..1b941b6
--- /dev/null
+++ b/uwac/templates/version.h.in
@@ -0,0 +1,32 @@
+/**
+ * FreeRDP: A Remote Desktop Protocol Implementation
+ * Version includes
+ *
+ * Copyright 2021 Thincast Technologies GmbH
+ * Copyright 2021 Armin Novak <armin.novak@thincast.com>
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+#ifndef UWAC_VERSION_H
+#define UWAC_VERSION_H
+
+#define UWAC_VERSION_MAJOR ${UWAC_VERSION_MAJOR}
+#define UWAC_VERSION_MINOR ${UWAC_VERSION_MINOR}
+#define UWAC_VERSION_REVISION ${UWAC_VERSION_REVISION}
+#define UWAC_VERSION_SUFFIX "${UWAC_VERSION_SUFFIX}"
+#define UWAC_API_VERSION "${UWAC_API_VERSION}"
+#define UWAC_VERSION "${UWAC_VERSION}"
+#define UWAC_VERSION_FULL "${UWAC_VERSION_FULL}"
+#define UWAC_GIT_REVISION "${GIT_REVISION}"
+
+#endif /* UWAC_VERSION_H */