summaryrefslogtreecommitdiffstats
path: root/channels/location/server/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'channels/location/server/CMakeLists.txt')
-rw-r--r--channels/location/server/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/channels/location/server/CMakeLists.txt b/channels/location/server/CMakeLists.txt
new file mode 100644
index 0000000..d37dc75
--- /dev/null
+++ b/channels/location/server/CMakeLists.txt
@@ -0,0 +1,28 @@
+# FreeRDP: A Remote Desktop Protocol Implementation
+# FreeRDP cmake build script
+#
+# Copyright 2023 Pascal Nowack <Pascal.Nowack@gmx.de>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+define_channel_server("location")
+
+set(${MODULE_PREFIX}_SRCS
+ location_main.c
+)
+
+set(${MODULE_PREFIX}_LIBS
+ freerdp
+)
+
+add_channel_server_library(${MODULE_PREFIX} ${MODULE_NAME} ${CHANNEL_NAME} FALSE "DVCPluginEntry")