summaryrefslogtreecommitdiffstats
path: root/client/SDL/man
diff options
context:
space:
mode:
Diffstat (limited to 'client/SDL/man')
-rw-r--r--client/SDL/man/CMakeLists.txt12
-rw-r--r--client/SDL/man/sdl-freerdp-config.1.xml.in81
-rw-r--r--client/SDL/man/sdl-freerdp-envvar.1.xml.in15
-rw-r--r--client/SDL/man/sdl-freerdp-examples.1.xml.in95
-rw-r--r--client/SDL/man/sdl-freerdp.1.xml.in67
5 files changed, 270 insertions, 0 deletions
diff --git a/client/SDL/man/CMakeLists.txt b/client/SDL/man/CMakeLists.txt
new file mode 100644
index 0000000..1fb2adc
--- /dev/null
+++ b/client/SDL/man/CMakeLists.txt
@@ -0,0 +1,12 @@
+set(DEPS
+ sdl-freerdp-channels.1.xml
+ sdl-freerdp-config.1.xml
+ sdl-freerdp-examples.1.xml
+ sdl-freerdp-envvar.1.xml
+ )
+
+set(MANPAGE_NAME ${PROJECT_NAME})
+if (WITH_BINARY_VERSIONING)
+ set(MANPAGE_NAME ${PROJECT_NAME}${PROJECT_VERSION_MAJOR})
+endif()
+generate_and_install_freerdp_man_from_xml(${PROJECT_NAME}.1 ${MANPAGE_NAME}.1 "${DEPS}")
diff --git a/client/SDL/man/sdl-freerdp-config.1.xml.in b/client/SDL/man/sdl-freerdp-config.1.xml.in
new file mode 100644
index 0000000..3bace73
--- /dev/null
+++ b/client/SDL/man/sdl-freerdp-config.1.xml.in
@@ -0,0 +1,81 @@
+<refsect1>
+ <title>Configuration file</title>
+
+ <variablelist>
+ <varlistentry>
+ <term>Format and Location:</term>
+ <listitem>
+ <para>The configuration file is stored per user.<sbr/>
+ The <replaceable>XDG_CONFIG_HOME</replaceable> environment variable can be used to override the base directory.<sbr/>
+ This defaults to <replaceable>~/.config</replaceable>
+ The location relative to <replaceable>XDG_CONFIG_HOME</replaceable> is <replaceable>$XDG_CONFIG_HOME/@VENDOR@/@PRODUCT@/@PROJECT_NAME@.json</replaceable><sbr/>
+ The configuration is stored in JSON format</para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term>Supported options:</term>
+ <listitem>
+ <varlistentry>
+ <term><replaceable>SDL_KeyModMask</replaceable></term>
+ <listitem>
+ <varlistentry>
+ <listitem>
+ <para>Defines the key combination required for SDL client shortcuts.<sbr/>
+ Default <replaceable>KMOD_RSHIFT</replaceable><sbr/>
+ An array of <replaceable>SDL_Keymod</replaceable> strings as defined at <replaceable>https://wiki.libsdl.org/SDL2/SDL_Keymod</replaceable></para>
+ </listitem>
+ </varlistentry>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><replaceable>SDL_Fullscreen</replaceable></term>
+ <listitem>
+ <varlistentry>
+ <listitem>
+ <para>Toggles client fullscreen state.<sbr/>
+ Default <replaceable>SDL_SCANCODE_RETURN</replaceable>.<sbr/>
+ A string as defined at <replaceable>https://wiki.libsdl.org/SDL2/SDLScancodeLookup</replaceable></para>
+ </listitem>
+ </varlistentry>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><replaceable>SDL_Resizeable</replaceable></term>
+ <listitem>
+ <varlistentry>
+ <listitem>
+ <para>Toggles local window resizeable state.<sbr/>
+ Default <replaceable>SDL_SCANCODE_R</replaceable>.<sbr/>
+ A string as defined at <replaceable>https://wiki.libsdl.org/SDL2/SDLScancodeLookup</replaceable></para>
+ </listitem>
+ </varlistentry>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><replaceable>SDL_Grab</replaceable></term>
+ <listitem>
+ <varlistentry>
+ <listitem>
+ <para>Toggles keyboard and mouse grab state.<sbr/>
+ Default <replaceable>SDL_SCANCODE_G</replaceable>.<sbr/>
+ A string as defined at <replaceable>https://wiki.libsdl.org/SDL2/SDLScancodeLookup</replaceable></para>
+ </listitem>
+ </varlistentry>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><replaceable>SDL_Disconnect</replaceable></term>
+ <listitem>
+ <varlistentry>
+ <listitem>
+ <para>Disconnects from the RDP session.<sbr/>
+ Default <replaceable>SDL_SCANCODE_D</replaceable>.<sbr/>
+ A string as defined at <replaceable>https://wiki.libsdl.org/SDL2/SDLScancodeLookup</replaceable></para>
+ </listitem>
+ </varlistentry>
+ </listitem>
+ </varlistentry>
+ </listitem>
+ </varlistentry>
+ </variablelist>
+</refsect1>
diff --git a/client/SDL/man/sdl-freerdp-envvar.1.xml.in b/client/SDL/man/sdl-freerdp-envvar.1.xml.in
new file mode 100644
index 0000000..ab6c8c5
--- /dev/null
+++ b/client/SDL/man/sdl-freerdp-envvar.1.xml.in
@@ -0,0 +1,15 @@
+<refsect1>
+ <title>Environment variables</title>
+
+ <variablelist>
+ <varlistentry>
+ <term>wlog environment variable</term>
+ <listitem>
+ <para>sdl-freerdp uses wLog as its log facility, you can refer to the
+ corresponding man page (wlog(7)) for more informations. Arguments passed
+ via the <replaceable>/log-level</replaceable> or <replaceable>/log-filters</replaceable>
+ have precedence over the environment variables.</para>
+ </listitem>
+ </varlistentry>
+ </variablelist>
+</refsect1>
diff --git a/client/SDL/man/sdl-freerdp-examples.1.xml.in b/client/SDL/man/sdl-freerdp-examples.1.xml.in
new file mode 100644
index 0000000..7b0f873
--- /dev/null
+++ b/client/SDL/man/sdl-freerdp-examples.1.xml.in
@@ -0,0 +1,95 @@
+<refsect1>
+ <title>Examples</title>
+ <variablelist>
+ <varlistentry>
+ <term><command>sdl-freerdp connection.rdp /p:Pwd123! /f</command></term>
+ <listitem>
+ <para>Connect in fullscreen mode using a stored configuration <replaceable>connection.rdp</replaceable> and the password <replaceable>Pwd123!</replaceable></para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><command>sdl-freerdp /u:USER /size:50%h /v:rdp.contoso.com</command></term>
+ <listitem>
+ <para>Connect to host <replaceable>rdp.contoso.com</replaceable> with user <replaceable>USER</replaceable> and a size of <replaceable>50 percent of the height</replaceable>. If width (w) is set instead of height (h) like /size:50%w. 50 percent of the width is used.</para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><command>sdl-freerdp /u:CONTOSO\\JohnDoe /p:Pwd123! /v:rdp.contoso.com</command></term>
+ <listitem>
+ <para>Connect to host <replaceable>rdp.contoso.com</replaceable> with user <replaceable>CONTOSO\\JohnDoe</replaceable> and password <replaceable>Pwd123!</replaceable></para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><command>sdl-freerdp /u:JohnDoe /p:Pwd123! /w:1366 /h:768 /v:192.168.1.100:4489</command></term>
+ <listitem>
+ <para>Connect to host <replaceable>192.168.1.100</replaceable> on port <replaceable>4489</replaceable> with user <replaceable>JohnDoe</replaceable>, password <replaceable>Pwd123!</replaceable>. The screen width is set to <replaceable>1366</replaceable> and the height to <replaceable>768</replaceable></para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><command>sdl-freerdp /u:JohnDoe /p:Pwd123! /vmconnect:C824F53E-95D2-46C6-9A18-23A5BB403532 /v:192.168.1.100</command></term>
+ <listitem>
+ <para>Establish a connection to host <replaceable>192.168.1.100</replaceable> with user <replaceable>JohnDoe</replaceable>, password <replaceable>Pwd123!</replaceable> and connect to Hyper-V console (use port 2179, disable negotiation) with VMID <replaceable>C824F53E-95D2-46C6-9A18-23A5BB403532</replaceable></para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><command>+clipboard</command></term>
+ <listitem>
+ <para>Activate clipboard redirection</para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><command>/drive:home,/home/user</command></term>
+ <listitem>
+ <para>Activate drive redirection of <replaceable>/home/user</replaceable> as home drive</para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><command>/smartcard:&lt;device&gt;</command></term>
+ <listitem>
+ <para>Activate smartcard redirection for device <replaceable>device</replaceable></para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><command>/printer:&lt;device&gt;,&lt;driver&gt;</command></term>
+ <listitem>
+ <para>Activate printer redirection for printer <replaceable>device</replaceable> using driver <replaceable>driver</replaceable></para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><command>/serial:&lt;device&gt;</command></term>
+ <listitem>
+ <para>Activate serial port redirection for port <replaceable>device</replaceable></para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><command>/parallel:&lt;device&gt;</command></term>
+ <listitem>
+ <para>Activate parallel port redirection for port <replaceable>device</replaceable></para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><command>/sound:sys:alsa</command></term>
+ <listitem>
+ <para>Activate audio output redirection using device <replaceable>sys:alsa</replaceable></para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><command>/microphone:sys:alsa</command></term>
+ <listitem>
+ <para>Activate audio input redirection using device <replaceable>sys:alsa</replaceable></para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><command>/multimedia:sys:alsa</command></term>
+ <listitem>
+ <para>Activate multimedia redirection using device <replaceable>sys:alsa</replaceable></para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><command>/usb:id,dev:054c:0268</command></term>
+ <listitem>
+ <para>Activate USB device redirection for the device identified by <replaceable>054c:0268</replaceable></para>
+ </listitem>
+ </varlistentry>
+ </variablelist>
+</refsect1>
diff --git a/client/SDL/man/sdl-freerdp.1.xml.in b/client/SDL/man/sdl-freerdp.1.xml.in
new file mode 100644
index 0000000..c4b9918
--- /dev/null
+++ b/client/SDL/man/sdl-freerdp.1.xml.in
@@ -0,0 +1,67 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!DOCTYPE refentry
+PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
+"http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
+ <!ENTITY syntax SYSTEM "freerdp-argument.1.xml">
+ <!ENTITY channels SYSTEM "sdl-freerdp-channels.1.xml">
+ <!ENTITY config SYSTEM "sdl-freerdp-config.1.xml">
+ <!ENTITY envvar SYSTEM "sdl-freerdp-envvar.1.xml">
+ <!ENTITY examples SYSTEM "sdl-freerdp-examples.1.xml">
+ ]
+>
+
+<refentry>
+ <refentryinfo>
+ <date>@MAN_TODAY@</date>
+ <author>
+ <authorblurb><para>The FreeRDP Team</para></authorblurb>
+ </author>
+ </refentryinfo>
+ <refmeta>
+ <refentrytitle>@MANPAGE_NAME@</refentrytitle>
+ <manvolnum>1</manvolnum>
+ <refmiscinfo class="source">freerdp</refmiscinfo>
+ <refmiscinfo class="manual">@MANPAGE_NAME@</refmiscinfo>
+ </refmeta>
+ <refnamediv>
+ <refname><application>@MANPAGE_NAME@</application></refname>
+ <refpurpose>FreeRDP SDL client</refpurpose>
+ </refnamediv>
+ <refsynopsisdiv>
+ <refsynopsisdivinfo>
+ <date>@MAN_TODAY@</date>
+ </refsynopsisdivinfo>
+ <para>
+ <command>@MANPAGE_NAME@</command> [file] [options] [/v:server[:port]]
+ </para>
+ </refsynopsisdiv>
+ <refsect1>
+ <refsect1info>
+ <date>@MAN_TODAY@</date>
+ </refsect1info>
+ <title>DESCRIPTION</title>
+ <para>
+ <command>@MANPAGE_NAME@</command> is an SDL Remote Desktop Protocol (RDP)
+ client which is part of the FreeRDP project. An RDP server is built-in
+ to many editions of Windows. Alternative servers included ogon, gnome-remote-desktop,
+ xrdp and VRDP (VirtualBox).
+ </para>
+ </refsect1>
+
+ &syntax;
+
+ &channels;
+
+ &config;
+
+ &envvar;
+
+ &examples;
+
+ <refsect1>
+ <title>LINKS</title>
+ <para>
+ <ulink url="http://www.freerdp.com/">http://www.freerdp.com/</ulink>
+ </para>
+ </refsect1>
+</refentry>