summaryrefslogtreecommitdiffstats
path: root/client/X11/man
diff options
context:
space:
mode:
Diffstat (limited to 'client/X11/man')
-rw-r--r--client/X11/man/CMakeLists.txt7
-rw-r--r--client/X11/man/xfreerdp-shortcuts.1.xml25
-rw-r--r--client/X11/man/xfreerdp.1.xml.in3
3 files changed, 30 insertions, 5 deletions
diff --git a/client/X11/man/CMakeLists.txt b/client/X11/man/CMakeLists.txt
index 386f13d..ed50e63 100644
--- a/client/X11/man/CMakeLists.txt
+++ b/client/X11/man/CMakeLists.txt
@@ -1,11 +1,8 @@
set(DEPS
xfreerdp-channels.1.xml
xfreerdp-examples.1.xml
+ xfreerdp-shortcuts.1.xml
xfreerdp-envvar.1.xml
)
-set(MANPAGE_NAME ${PROJECT_NAME})
-if (WITH_BINARY_VERSIONING)
- set(MANPAGE_NAME ${PROJECT_NAME}${PROJECT_VERSION_MAJOR})
-endif()
-generate_and_install_freerdp_man_from_xml(${PROJECT_NAME}.1 ${MANPAGE_NAME}.1 ${DEPS})
+generate_and_install_freerdp_man_from_xml("xfreerdp" "1" "${FREERDP_API_VERSION}" ${DEPS})
diff --git a/client/X11/man/xfreerdp-shortcuts.1.xml b/client/X11/man/xfreerdp-shortcuts.1.xml
new file mode 100644
index 0000000..a6b96ea
--- /dev/null
+++ b/client/X11/man/xfreerdp-shortcuts.1.xml
@@ -0,0 +1,25 @@
+<refsect1>
+ <title>Keyboard Shortcuts</title>
+ <variablelist>
+ <varlistentry>
+ <term>&lt;Right CTRL&gt;</term>
+ <listitem><para>releases keyboard and mouse grab</para></listitem>
+ </varlistentry>
+ <varlistentry>
+ <term>&lt;CTRL&gt;+&lt;ALT&gt;+&lt;Return&gt;</term>
+ <listitem><para>toggles fullscreen state of the application</para></listitem>
+ </varlistentry>
+ <varlistentry>
+ <term>&lt;CTRL&gt;+&lt;ALT&gt;+c</term>
+ <listitem><para>toggles remote control in a remote assistance session</para></listitem>
+ </varlistentry>
+ <varlistentry>
+ <term>Action Script</term>
+ <listitem><para>executes a predefined script on key press.</para></listitem>
+ <listitem><para>Should the script not exist it is ignored.</para></listitem>
+ <listitem><para>Scripts can be provided at the default localtion ~/.config/freerdp/action.sh or as command line argument /action:script:&lt;path&gt;.</para></listitem>
+ <listitem><para>The script will receive the current key combination as argument.</para></listitem>
+ <listitem><para>The output of the script is parsed for key-local which tells that the script used the key combination, otherwise the combination is forwarded to the remote.</para></listitem>
+ </varlistentry>
+ </variablelist>
+</refsect1>
diff --git a/client/X11/man/xfreerdp.1.xml.in b/client/X11/man/xfreerdp.1.xml.in
index 271e39d..7e7c782 100644
--- a/client/X11/man/xfreerdp.1.xml.in
+++ b/client/X11/man/xfreerdp.1.xml.in
@@ -3,6 +3,7 @@
PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
"http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
<!ENTITY syntax SYSTEM "freerdp-argument.1.xml">
+ <!ENTITY shortcuts SYSTEM "xfreerdp-shortcuts.1.xml">
<!ENTITY channels SYSTEM "xfreerdp-channels.1.xml">
<!ENTITY envvar SYSTEM "xfreerdp-envvar.1.xml">
<!ENTITY examples SYSTEM "xfreerdp-examples.1.xml">
@@ -49,6 +50,8 @@ PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
&syntax;
+ &shortcuts;
+
&channels;
&envvar;