summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 01d7e5e..443f066 100755
--- a/debian/rules
+++ b/debian/rules
@@ -108,6 +108,7 @@ endif
xSEDx :=$(shell printf '\026')
override_dh_auto_configure:
+ dh_auto_configure --builddirectory=debian/testtmp -- $(DEB_CMAKE_EXTRA_FLAGS) -DBUILD_TESTING=ON
dh_auto_configure -- $(DEB_CMAKE_EXTRA_FLAGS)
# mangle CFLAGS value stored in buildflags.h.
# fixes build path leakage.
@@ -121,6 +122,12 @@ override_dh_auto_configure:
-e "s$(xSEDx) $${o}=[^=]+=\.$(xSEDx)$(xSEDx)g;" \
obj-$(DEB_HOST_GNU_TYPE)/winpr/include/winpr/buildflags.h
+execute_after_dh_auto_build:
+ dh_auto_build --builddirectory=debian/testtmp
+
+execute_after_dh_auto_test:
+ dh_auto_test --builddirectory=debian/testtmp
+
# NB debhelper 13+: convert to execute_before_dh_install
override_dh_install: TMP_LIB = debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)
override_dh_install: