summaryrefslogtreecommitdiffstats
path: root/winpr/libwinpr/synch/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'winpr/libwinpr/synch/CMakeLists.txt')
-rw-r--r--winpr/libwinpr/synch/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/winpr/libwinpr/synch/CMakeLists.txt b/winpr/libwinpr/synch/CMakeLists.txt
new file mode 100644
index 0000000..84053aa
--- /dev/null
+++ b/winpr/libwinpr/synch/CMakeLists.txt
@@ -0,0 +1,40 @@
+# WinPR: Windows Portable Runtime
+# libwinpr-synch cmake build script
+#
+# Copyright 2012 Marc-Andre Moreau <marcandre.moreau@gmail.com>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+winpr_module_add(
+ address.c
+ barrier.c
+ critical.c
+ event.c
+ init.c
+ mutex.c
+ pollset.c
+ pollset.h
+ semaphore.c
+ sleep.c
+ synch.h
+ timer.c
+ wait.c)
+
+if(FREEBSD)
+ winpr_include_directory_add(${EPOLLSHIM_INCLUDE_DIR})
+ winpr_library_add_private(${EPOLLSHIM_LIBS})
+endif()
+
+if(BUILD_TESTING)
+ add_subdirectory(test)
+endif()