summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:39:04 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:39:04 +0000
commitffca2751af51fab0be19f0011dd4e131f72b3e6a (patch)
tree6fa3da56d69f990b973618097442fbfc9ef8c759 /debian/patches
parentAdding upstream version 1.1.1. (diff)
downloadfrozen-debian.tar.xz
frozen-debian.zip
Adding debian version 1.1.1-3.debian/1.1.1-3debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/079f73cc5c6413127d47f325cbb34a607e2cb030.patch37
-rw-r--r--debian/patches/cstdint.diff18
-rw-r--r--debian/patches/no-werror.diff19
-rw-r--r--debian/patches/series3
4 files changed, 77 insertions, 0 deletions
diff --git a/debian/patches/079f73cc5c6413127d47f325cbb34a607e2cb030.patch b/debian/patches/079f73cc5c6413127d47f325cbb34a607e2cb030.patch
new file mode 100644
index 0000000..1ce542e
--- /dev/null
+++ b/debian/patches/079f73cc5c6413127d47f325cbb34a607e2cb030.patch
@@ -0,0 +1,37 @@
+From 079f73cc5c6413127d47f325cbb34a607e2cb030 Mon Sep 17 00:00:00 2001
+From: serge-sans-paille <serge.guelton@telecom-bretagne.eu>
+Date: Fri, 16 Dec 2022 22:58:51 +0100
+Subject: [PATCH] Workaround gcc 11 limitation
+
+For some reason, gcc sees a constexpr violation here. Trust clang and msvc on this.
+---
+ include/frozen/unordered_set.h | 2 +-
+ tests/test_unordered_set.cpp | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/include/frozen/unordered_set.h b/include/frozen/unordered_set.h
+index 4d16df9..196ea50 100644
+--- a/include/frozen/unordered_set.h
++++ b/include/frozen/unordered_set.h
+@@ -105,7 +105,7 @@ class unordered_set {
+ /* lookup */
+ template <class KeyType, class Hasher, class Equal>
+ constexpr std::size_t count(KeyType const &key, Hasher const &hash, Equal const &equal) const {
+- auto const k = lookup(key, hash);
++ auto const & k = lookup(key, hash);
+ return equal(k, key);
+ }
+ template <class KeyType>
+diff --git a/tests/test_unordered_set.cpp b/tests/test_unordered_set.cpp
+index e90a0d4..042c1a8 100644
+--- a/tests/test_unordered_set.cpp
++++ b/tests/test_unordered_set.cpp
+@@ -65,7 +65,7 @@ TEST_CASE("tripleton str frozen unordered set", "[unordered set]") {
+ constexpr auto max_size = ze_set.max_size();
+ REQUIRE(max_size == 3);
+
+- constexpr auto nocount = ze_set.count(4);
++ const auto nocount = ze_set.count(4);
+ REQUIRE(nocount == 0);
+
+ constexpr auto count = ze_set.count(1);
diff --git a/debian/patches/cstdint.diff b/debian/patches/cstdint.diff
new file mode 100644
index 0000000..c4cbb7f
--- /dev/null
+++ b/debian/patches/cstdint.diff
@@ -0,0 +1,18 @@
+Description: fix build with gcc 13
+Author: Rene Engelhard <rene@debian.org>
+
+---
+Origin: vendor
+Forwarded: no
+Last-Update: 2023-07-24
+
+--- frozen-1.1.1.orig/include/frozen/bits/pmh.h
++++ frozen-1.1.1/include/frozen/bits/pmh.h
+@@ -29,6 +29,7 @@
+
+ #include <array>
+ #include <limits>
++#include <cstdint>
+
+ namespace frozen {
+
diff --git a/debian/patches/no-werror.diff b/debian/patches/no-werror.diff
new file mode 100644
index 0000000..8f1e911
--- /dev/null
+++ b/debian/patches/no-werror.diff
@@ -0,0 +1,19 @@
+Description: don't use -Werror
+Author: Rene Engelhard <rene@debian.org>
+
+---
+Origin: vendor
+Forwarded: no
+Last-Update: 2023-07-24
+
+--- frozen-1.1.1.orig/tests/CMakeLists.txt
++++ frozen-1.1.1/tests/CMakeLists.txt
+@@ -28,7 +28,7 @@ string(CONCAT generator
+ "$<$<OR:$<CXX_COMPILER_ID:GNU>"
+ ",$<CXX_COMPILER_ID:Clang>"
+ ",$<CXX_COMPILER_ID:AppleClang>>"
+- ":-Wall;-Wextra;-Wpedantic;-Werror;-Wshadow;"
++ ":-Wall;-Wextra;-Wpedantic;-Wshadow;"
+ "$<$<BOOL:${frozen.coverage}>:--coverage>>"
+ "$<$<CXX_COMPILER_ID:Intel>:"
+ "$<$<PLATFORM_ID:Windows>:/W3;/WX;>"
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..5458708
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,3 @@
+079f73cc5c6413127d47f325cbb34a607e2cb030.patch
+cstdint.diff
+no-werror.diff