summaryrefslogtreecommitdiffstats
path: root/doc/developer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'doc/developer/Makefile')
-rw-r--r--doc/developer/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/doc/developer/Makefile b/doc/developer/Makefile
new file mode 100644
index 0000000..38afb43
--- /dev/null
+++ b/doc/developer/Makefile
@@ -0,0 +1,16 @@
+all: ALWAYS
+ @$(MAKE) -s -C ../.. developer-html
+help: ALWAYS
+ @$(MAKE) -s -C ../.. doc/help
+pdf: ALWAYS
+ @$(MAKE) -s -C ../.. doc/developer/_build/latexpdf
+info: ALWAYS
+ @$(MAKE) -s -C ../.. doc/developer/_build/texinfo/frr.info
+%: ALWAYS
+ @$(MAKE) -s -C ../.. doc/developer/_build/$@
+
+Makefile:
+ #nothing
+ALWAYS:
+.PHONY: ALWAYS makefiles
+.SUFFIXES: