summaryrefslogtreecommitdiffstats
path: root/redhat/frr.spec.in
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/frr.spec.in')
-rw-r--r--redhat/frr.spec.in59
1 files changed, 40 insertions, 19 deletions
diff --git a/redhat/frr.spec.in b/redhat/frr.spec.in
index f43d0c1..bd9edd1 100644
--- a/redhat/frr.spec.in
+++ b/redhat/frr.spec.in
@@ -16,6 +16,7 @@
%{!?with_cumulus: %global with_cumulus 0 }
%{!?with_eigrpd: %global with_eigrpd 1 }
%{!?with_fpm: %global with_fpm 1 }
+%{!?with_mgmtd_test_be_client: %global with_mgmtd_test_be_client 0 }
%{!?with_ldpd: %global with_ldpd 1 }
%{!?with_multipath: %global with_multipath 256 }
%{!?with_nhrpd: %global with_nhrpd 1 }
@@ -42,8 +43,9 @@
%define zeb_docs %{zeb_src}/doc
%define frr_tools %{zeb_src}/tools
-# defines for configure
-%define rundir %{_localstatedir}/run/%{name}
+%if 0%{!?_runstatedir:1}
+%define _runstatedir %{_localstatedir}/run
+%endif
############################################################################
@@ -180,6 +182,7 @@ BuildRequires: flex
BuildRequires: gcc
BuildRequires: json-c-devel
BuildRequires: libcap-devel
+BuildRequires: protobuf-c-devel
BuildRequires: make
BuildRequires: ncurses-devel
BuildRequires: readline-devel
@@ -316,11 +319,13 @@ routing state through standard SNMP MIBs.
%configure \
--sbindir=%{_sbindir} \
- --sysconfdir=%{configdir} \
- --localstatedir=%{rundir} \
+ --sysconfdir=%{_sysconfdir} \
+ --localstatedir=%{_localstatedir} \
--disable-static \
--disable-werror \
- --enable-irdp \
+%if %{with_mgmtd_test_be_client}
+ --enable-mgmtd-test-be-client \
+%endif
%if %{with_multipath}
--enable-multipath=%{with_multipath} \
%endif
@@ -470,7 +475,7 @@ install %{zeb_src}/tools/etc/frr/daemons %{buildroot}%{_sysconfdir}/frr
install %{zeb_src}/tools/etc/frr/frr.conf %{buildroot}%{_sysconfdir}/frr/frr.conf.template
install -m644 %{zeb_rh_src}/frr.pam %{buildroot}%{_sysconfdir}/pam.d/frr
install -m644 %{zeb_src}/tools/etc/logrotate.d/frr %{buildroot}%{_sysconfdir}/logrotate.d/frr
-install -d -m750 %{buildroot}%{rundir}
+install -d -m750 %{buildroot}%{_runstatedir}/frr
%if 0%{?rhel} > 7 || 0%{?fedora} > 29
# avoid `ERROR: ambiguous python shebang in` errors
@@ -494,7 +499,7 @@ rm -f %{buildroot}%{_sbindir}/ospfclient.py
getent passwd %{frr_user} >/dev/null || \
useradd -r -u %{frr_uid} -g %{frr_user} \
-s /sbin/nologin -c "FRRouting suite" \
- -d %{rundir} %{frr_user}
+ -d %{_runstatedir}/frr %{frr_user}
%if 0%{?vty_group:1}
usermod -a -G %{vty_group} %{frr_user}
@@ -654,11 +659,11 @@ fi
%if 0%{?frr_user:1}
%dir %attr(751,%{frr_user},%{frr_user}) %{configdir}
%dir %attr(755,%{frr_user},%{frr_user}) %{_localstatedir}/log/frr
- %dir %attr(751,%{frr_user},%{frr_user}) %{rundir}
+ %dir %attr(751,%{frr_user},%{frr_user}) %{_runstatedir}/frr
%else
%dir %attr(750,root,root) %{configdir}
%dir %attr(755,root,root) %{_localstatedir}/log/frr
- %dir %attr(750,root,root) %{rundir}
+ %dir %attr(750,root,root) %{_runstatedir}/frr
%endif
%{_infodir}/frr.info.gz
%{_mandir}/man*/*
@@ -668,6 +673,9 @@ fi
%{_sbindir}/ripd
%{_sbindir}/bgpd
%{_sbindir}/mgmtd
+%if %{with_mgmtd_test_be_client}
+ %{_sbindir}/mgmtd_testc
+%endif
%exclude %{_sbindir}/ssd
%if %{with_watchfrr}
%{_sbindir}/watchfrr
@@ -715,7 +723,6 @@ fi
%endif
%{_libdir}/frr/modules/zebra_cumulus_mlag.so
%{_libdir}/frr/modules/dplane_fpm_nl.so
-%{_libdir}/frr/modules/zebra_irdp.so
%{_libdir}/frr/modules/bgpd_bmp.so
%{_libdir}/libfrr_pb.so*
%{_libdir}/libfrrfpm_pb.so*
@@ -779,8 +786,6 @@ sed -i 's/ -M rpki//' %{_sysconfdir}/frr/daemons
%{_libdir}/lib*.so
%dir %{_includedir}/%{name}
%{_includedir}/%{name}/*.h
-%dir %{_includedir}/%{name}/mgmtd
-%{_includedir}/%{name}/mgmtd/*.h
%dir %{_includedir}/%{name}/ospfd
%{_includedir}/%{name}/ospfd/*.h
%if %{with_bfdd}
@@ -799,9 +804,23 @@ sed -i 's/ -M rpki//' %{_sysconfdir}/frr/daemons
%changelog
-* Thu Oct 09 2023 Donatas Abraitis <donatas@opensourcerouting.org> - %{version}
+* Mon Apr 08 2024 Jafar Al-Gharaibeh <jafar@atcorp.com> - %{version}
-* Thu Oct 09 2023 Donatas Abraitis <donatas@opensourcerouting.org> - 9.1
+* Mon Apr 08 2024 Jafar Al-Gharaibeh <jafar@atcorp.com> - 10.0
+- Major highlights:
+- Introduce local host routes
+- Require libyang 2.1.128
+- Add suport to configire a log file per daemon
+- BGP BMP Loc-RIB (RFC9069) support
+- eBGP-OAD (One Administrative Domain) support
+- BGP RPKI VRF support
+- BGP SNMP traps for BGP4-MIBV2
+- Management (mgmtd) daemon "replace" operation support
+- BGP dynamic capabilities for addpath, fqdn, orf capabilities
+- SRv6 encapsulation source address feature
+- OSPFv3 Point-To-Multipoint mode
+
+* Mon Oct 09 2023 Donatas Abraitis <donatas@opensourcerouting.org> - 9.1
- Major highlights:
- OSPFv2 HMAC-SHA Cryptographic Authentication
- BGP MAC-VRF Site-Of-Origin support
@@ -821,18 +840,20 @@ sed -i 's/ -M rpki//' %{_sysconfdir}/frr/daemons
- Memory footprint for BGP reduced drastically
- Add BGP `neighbor path-attribute treat-as-withdraw` command
- Add BGP ASN dot notation support (RFC 5396)
-- Add BGP Software Version capability (draft-abraitis-bgp-version-capability)
+- Add BGP Software Version capability
- Allow BGP peering via 127.0.0.0/8
-- Deprecate BGP internet community - this is the Cisco-specific community, which is never been RFC-defined and confusing
+- Deprecate BGP `internet` community - this is the Cisco-specific community, which is never been RFC-defined and confusing
- Implement `match source-protocol` for BGP route maps
- Implement BGP Node Target extended communities (draft-ietf-idr-node-target-ext-comm)
- Implement Flex-Algo for SR-MPLS (RFC 9350)
-- Add support for IS-IS advertise-passive-only
-- Add IS-IS affinity-map support
-- Add the graceful-restart hello-delay OSPFv2/OSPFv3 command
+- Add support for IS-IS `advertise-passive-only`
+- Add IS-IS `affinity-map` support
+- Add the `graceful-restart hello-delay` OSPFv2/OSPFv3 command
- Add the `ipv6 mld join` PIMv6 command
- Add `allow-ecmp x` RIP/RIPng command
- Add BFD support for RIP
+- For a full list of new features and bug fixes, please refer to:
+- https://frrouting.org/release/
* Fri Mar 10 2023 Jafar Al-Gharaibeh <jafar@atcorp.com> - 8.5
- Major Highlights: