summaryrefslogtreecommitdiffstats
path: root/debian/patches/pr67590.diff
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:58:36 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:58:36 +0000
commit1d3b23e6bdbf53eb74161c37d8c355c2ec858a19 (patch)
treee279a67ec4f447e99b0754e7964666f7b48b5c05 /debian/patches/pr67590.diff
parentAdding upstream version 14-20240201. (diff)
downloadgcc-14-1d3b23e6bdbf53eb74161c37d8c355c2ec858a19.tar.xz
gcc-14-1d3b23e6bdbf53eb74161c37d8c355c2ec858a19.zip
Adding debian version 14-20240201-3.debian/14-20240201-3debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches/pr67590.diff')
-rw-r--r--debian/patches/pr67590.diff36
1 files changed, 36 insertions, 0 deletions
diff --git a/debian/patches/pr67590.diff b/debian/patches/pr67590.diff
new file mode 100644
index 0000000..0b3adfa
--- /dev/null
+++ b/debian/patches/pr67590.diff
@@ -0,0 +1,36 @@
+# DP: Fix PR67590, setting objdump macro.
+
+--- a/src/libcc1/configure.ac
++++ b/src/libcc1/configure.ac
+@@ -74,6 +74,31 @@ if test "$GXX" = yes; then
+ fi
+ AC_SUBST(libsuffix)
+
++# Figure out what objdump we will be using.
++AS_VAR_SET_IF(gcc_cv_objdump,, [
++if test -f $gcc_cv_binutils_srcdir/configure.ac \
++ && test -f ../binutils/Makefile \
++ && test x$build = x$host; then
++ # Single tree build which includes binutils.
++ gcc_cv_objdump=../binutils/objdump$build_exeext
++elif test -x objdump$build_exeext; then
++ gcc_cv_objdump=./objdump$build_exeext
++elif ( set dummy $OBJDUMP_FOR_TARGET; test -x $[2] ); then
++ gcc_cv_objdump="$OBJDUMP_FOR_TARGET"
++else
++ AC_PATH_PROG(gcc_cv_objdump, $OBJDUMP_FOR_TARGET)
++fi])
++
++AC_MSG_CHECKING(what objdump to use)
++if test "$gcc_cv_objdump" = ../binutils/objdump$build_exeext; then
++ # Single tree build which includes binutils.
++ AC_MSG_RESULT(newly built objdump)
++elif test x$gcc_cv_objdump = x; then
++ AC_MSG_RESULT(not found)
++else
++ AC_MSG_RESULT($gcc_cv_objdump)
++fi
++
+ dnl Test for -lsocket and -lnsl. Copied from libgo/configure.ac.
+ AC_CACHE_CHECK([for socket libraries], libcc1_cv_lib_sockets,
+ [libcc1_cv_lib_sockets=