summaryrefslogtreecommitdiffstats
path: root/debian/patches/gcc-target-include-asm.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/gcc-target-include-asm.diff')
-rw-r--r--debian/patches/gcc-target-include-asm.diff13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/patches/gcc-target-include-asm.diff b/debian/patches/gcc-target-include-asm.diff
new file mode 100644
index 0000000..7a27a8b
--- /dev/null
+++ b/debian/patches/gcc-target-include-asm.diff
@@ -0,0 +1,13 @@
+# DP: Search $(builddir)/sys-include for the asm header files
+
+--- a/src/configure.ac
++++ b/src/configure.ac
+@@ -3601,7 +3601,7 @@ fi
+ # being built; programs in there won't even run.
+ if test "${build}" = "${host}" && test -d ${srcdir}/gcc; then
+ # Search for pre-installed headers if nothing else fits.
+- FLAGS_FOR_TARGET=$FLAGS_FOR_TARGET' -B$(build_tooldir)/bin/ -B$(build_tooldir)/lib/ -isystem $(build_tooldir)/include -isystem $(build_tooldir)/sys-include'
++ FLAGS_FOR_TARGET=$FLAGS_FOR_TARGET' -B$(build_tooldir)/bin/ -B$(build_tooldir)/lib/ -isystem $(build_tooldir)/include -isystem $(build_tooldir)/sys-include -isystem $(CURDIR)/sys-include'
+ fi
+
+ if test "x${use_gnu_ld}" = x &&