summaryrefslogtreecommitdiffstats
path: root/test/Makefile.vc
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:22:53 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:22:53 +0000
commit3b149631f0eb732049e04fa0c89d09c7aa2376f9 (patch)
tree7049356b06fcdcdaf9dbae476f55a43942e7c25f /test/Makefile.vc
parentInitial commit. (diff)
downloadgeoip-3b149631f0eb732049e04fa0c89d09c7aa2376f9.tar.xz
geoip-3b149631f0eb732049e04fa0c89d09c7aa2376f9.zip
Adding upstream version 1.6.12.upstream/1.6.12upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/Makefile.vc')
-rw-r--r--test/Makefile.vc29
1 files changed, 29 insertions, 0 deletions
diff --git a/test/Makefile.vc b/test/Makefile.vc
new file mode 100644
index 0000000..db80c10
--- /dev/null
+++ b/test/Makefile.vc
@@ -0,0 +1,29 @@
+#NMAKE makefile for Windows developers.
+#Produces a static library (GeoIP.lib).
+
+COMPILER=cl
+
+LINK = link -nologo
+
+CFLAGS=-DWIN32 -MD -nologo
+
+GEOIPINC = -I..\libGeoIP
+
+CC1 = $(COMPILER) $(CFLAGS) $(GEOIPINC) -DSRCDIR=\"../\"
+
+GEOIPLIB = ..\libGeoIP\GeoIP.lib
+
+EXTRA_LIBS= advapi32.lib wsock32.lib
+
+AR=lib
+
+TEST: benchmark.exe test-geoip.exe
+
+benchmark.exe: benchmark.c
+ $(CC1) -c benchmark.c
+ $(LINK) benchmark.obj $(GEOIPLIB)
+
+test-geoip.exe: test-geoip.c
+ $(CC1) -c test-geoip.c
+ $(LINK) test-geoip.obj $(GEOIPLIB)
+