summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..ad9b1ea
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,15 @@
+AM_CPPFLAGS = -Wall -ansi
+ACLOCAL_AMFLAGS = -I m4
+
+AUTOMAKE_OPTIONS = foreign
+
+SUBDIRS = \
+ libGeoIP \
+ apps \
+ test \
+ man
+
+pkgconfigdir = $(libdir)/pkgconfig/
+nodist_pkgconfig_DATA = geoip.pc
+
+EXTRA_DIST = LICENSE NEWS.md README.md README.OSX bootstrap GeoIP.spec GeoIP.spec.in Makefile.vc get_ver.awk geoip.ico geoip.pc.in data/GeoIP.dat