summaryrefslogtreecommitdiffstats
path: root/apps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'apps/Makefile.am')
-rw-r--r--apps/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/apps/Makefile.am b/apps/Makefile.am
new file mode 100644
index 0000000..6e2a49c
--- /dev/null
+++ b/apps/Makefile.am
@@ -0,0 +1,18 @@
+AM_CPPFLAGS = -I$(top_srcdir)/libGeoIP -DSYSCONFDIR=\"$(sysconfdir)\" -Wall
+
+DEPS = $(top_builddir)/libGeoIP/libGeoIP.la
+LDADDS = $(top_builddir)/libGeoIP/libGeoIP.la
+
+bin_PROGRAMS = geoiplookup geoiplookup6
+
+geoiplookup_SOURCES = geoiplookup.c
+geoiplookup_LDFLAGS =
+geoiplookup_DEPENDENCIES = $(top_builddir)/libGeoIP/libGeoIP.la
+geoiplookup_LDADD = $(top_builddir)/libGeoIP/libGeoIP.la
+
+geoiplookup6_SOURCES = geoiplookup6.c
+geoiplookup6_LDFLAGS =
+geoiplookup6_DEPENDENCIES = $(top_builddir)/libGeoIP/libGeoIP.la
+geoiplookup6_LDADD = $(top_builddir)/libGeoIP/libGeoIP.la
+
+EXTRA_DIST = Makefile.vc