summaryrefslogtreecommitdiffstats
path: root/apps/Makefile.vc
diff options
context:
space:
mode:
Diffstat (limited to 'apps/Makefile.vc')
-rw-r--r--apps/Makefile.vc25
1 files changed, 25 insertions, 0 deletions
diff --git a/apps/Makefile.vc b/apps/Makefile.vc
new file mode 100644
index 0000000..266a931
--- /dev/null
+++ b/apps/Makefile.vc
@@ -0,0 +1,25 @@
+#NMAKE makefile for Windows developers.
+#Produces a static library (GeoIP.lib).
+
+COMPILER=cl
+
+LINK = link -nologo
+
+CFLAGS=-DWIN32 -MD -nologo
+
+GEOIPINC = -I..\libGeoIP
+
+CC1 = $(COMPILER) $(CFLAGS) $(GEOIPINC)
+
+GEOIPLIB = ..\libGeoIP\GeoIP.lib
+
+EXTRA_LIBS= advapi32.lib wsock32.lib
+
+AR=lib
+
+APPS: geoiplookup.exe
+
+geoiplookup.exe: geoiplookup.c
+ $(CC1) -c geoiplookup.c
+ $(LINK) geoiplookup.obj $(GEOIPLIB)
+