summaryrefslogtreecommitdiffstats
path: root/man
diff options
context:
space:
mode:
Diffstat (limited to 'man')
-rw-r--r--man/Makefile.am26
-rw-r--r--man/geoiplookup.1.in37
-rw-r--r--man/geoiplookup6.1.in42
3 files changed, 105 insertions, 0 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
new file mode 100644
index 0000000..1615d54
--- /dev/null
+++ b/man/Makefile.am
@@ -0,0 +1,26 @@
+man_MANS = geoiplookup6.1 geoiplookup.1
+
+EXTRA_DIST = geoiplookup6.1.in geoiplookup.1.in
+
+
+edit = sed \
+ -e 's|DATADIR|$(pkgdatadir)|g' \
+ -e 's|CONF_DIR|$(sysconfdir)|g'
+
+geoiplookup.1 geoiplookup6.1: Makefile
+ rm -f $@ $@.tmp
+ $(edit) '$(srcdir)/$@.in' >$@.tmp
+ mv $@.tmp $@
+
+geoiplookup.1: geoiplookup.1.in
+geoiplookup6.1: geoiplookup6.1.in
+
+CLEANFILES = geoiplookup6.1 geoiplookup.1
+
+LOOKUP_MAN = $(mandir)/man1/geoiplookup.1
+LOOKUP6_MAN = $(mandir)/man1/geoiplookup6.1
+
+install-data-hook:
+ cat geoiplookup.1 | sed s,DATADIR,$(pkgdatadir), > $(DESTDIR)$(LOOKUP_MAN)
+ cat geoiplookup6.1 | sed s,DATADIR,$(pkgdatadir), > $(DESTDIR)$(LOOKUP6_MAN)
+
diff --git a/man/geoiplookup.1.in b/man/geoiplookup.1.in
new file mode 100644
index 0000000..010e58f
--- /dev/null
+++ b/man/geoiplookup.1.in
@@ -0,0 +1,37 @@
+.TH GEOIPLOOKUP 1 "2 Jan 2007"
+.UC 4
+.SH NAME
+geoiplookup \- look up country using IP Address or hostname
+.SH SYNOPSIS
+geoiplookup [\-d directory] [\-f filename] [\-v] <ipaddress|hostname>
+.SH DESCRIPTION
+geoiplookup uses the GeoIP library and database to find the Country
+that an IP address or hostname originates from.
+.PP
+For example
+.PP
+.I geoiplookup 80.60.233.195
+.PP
+will find the Country that 80.60.233.195 originates from, in the following format:
+.PP
+.I NL, Netherlands
+.PP
+.SH OPTIONS
+.IP "\-f"
+Specify a custom path to a single GeoIP datafile.
+.IP "\-d"
+Specify a custom directory containing GeoIP datafile(s). By default geoiplookup looks in DATADIR
+.IP "\-v"
+Lists the date and build number for the GeoIP datafile(s).
+.SH AUTHOR
+Written by T.J. Mather
+.SH "REPORTING BUGS"
+Report bugs to <support@maxmind.com>
+.SH COPYRIGHT
+Copyright (C) 2016 MaxMind, Inc.
+
+This is free software; see the source for copying conditions.
+There is NO warranty; not even for MERCHANTABILITY
+or FITNESS FOR A PARTICULAR PURPOSE.
+.SH "SEE ALSO"
+geoipupdate(1), nslookup(1).
diff --git a/man/geoiplookup6.1.in b/man/geoiplookup6.1.in
new file mode 100644
index 0000000..8816e47
--- /dev/null
+++ b/man/geoiplookup6.1.in
@@ -0,0 +1,42 @@
+.TH GEOIPLOOKUP6 1 "28 Oct 2008"
+.UC 4
+.SH NAME
+geouplookup6 \- look up country using IP Address or hostname
+.SH SYNOPSIS
+geouplookup6 [\-d directory] [\-f filename] [\-v] <ipaddress|hostname>
+.SH DESCRIPTION
+geouplookup6 uses the GeoIP library and database to find the Country
+that an IP address or hostname originates from. You must install a database suitable for geoiplookup6. IE: GeoIPv6.dat
+.PP
+For example:
+.PP
+.I geouplookup6 2001:4860:0:1001::68
+.PP
+.I geoiplookup6 ipv6.google.com
+.PP
+will find the Country that 2001:4860:0:1001::68 originates from, in the following format:
+.PP
+.I US, United States
+.PP
+.PP Please notice, that names must resolve to a ipv6 address. For example
+.PP geoiplookup6 www.maxmind.com does not work, since there is no ipv6
+.PP DNS entry
+.SH OPTIONS
+.IP "\-f"
+Specify a custom path to a single GeoIP datafile.
+.IP "\-d"
+Specify a custom directory containing GeoIP datafile(s). By default geouplookup6 looks in DATADIR
+.IP "\-v"
+Lists the date and build number for the GeoIP datafile(s).
+.SH AUTHOR
+Written by T.J. Mather
+.SH "REPORTING BUGS"
+Report bugs to <support@maxmind.com>
+.SH COPYRIGHT
+Copyright (C) 2008 MaxMind LLC
+
+This is free software; see the source for copying conditions.
+There is NO warranty; not even for MERCHANTABILITY
+or FITNESS FOR A PARTICULAR PURPOSE.
+.SH "SEE ALSO"
+geoipupdate(1), nslookup(1).