summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..8c38178
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,38 @@
+check_PROGRAMS = test-geoip test-geoip-invalid-file
+
+noinst_PROGRAMS = benchmark test-geoip-region test-geoip-city test-geoip-org test-geoip-domain test-geoip-asnum test-geoip-isp test-geoip-netspeed
+
+EXTRA_PROGRAMS = benchmark \
+ test-geoip-region \
+ test-geoip-city \
+ test-geoip-org \
+ test-geoip-domain \
+ test-geoip-asnum \
+ test-geoip-isp \
+ test-geoip-netspeed
+
+LDADD = $(top_builddir)/libGeoIP/libGeoIP.la
+AM_CPPFLAGS = -I$(top_srcdir)/libGeoIP -DSRCDIR=\"$(top_srcdir)\" -Wall
+
+test_geoip_SOURCES = test-geoip.c
+
+test_geoip_invalid_file_SOURCES = test-geoip-invalid-file.c
+
+test_geoip_region_SOURCES = test-geoip-region.c
+
+test_geoip_org_SOURCES = test-geoip-org.c
+
+test_geoip_domain_SOURCES = test-geoip-domain.c
+
+test_geoip_isp_SOURCES = test-geoip-isp.c
+
+test_geoip_asnum_SOURCES = test-geoip-asnum.c
+
+test_geoip_netspeed_SOURCES = test-geoip-netspeed.c
+
+test_geoip_city_SOURCES = test-geoip-city.c
+
+benchmark_SOURCES = benchmark.c
+
+EXTRA_DIST = Makefile.vc city_test.txt country_test.txt country_test2.txt country_test_name.txt region_test.txt
+TESTS = test-geoip test-geoip-invalid-file