summaryrefslogtreecommitdiffstats
path: root/devel-docs/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 03:13:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 03:13:10 +0000
commit3c57dd931145d43f2b0aef96c4d178135956bf91 (patch)
tree3de698981e9f0cc2c4f9569b19a5f3595e741f6b /devel-docs/Makefile.am
parentInitial commit. (diff)
downloadgimp-3c57dd931145d43f2b0aef96c4d178135956bf91.tar.xz
gimp-3c57dd931145d43f2b0aef96c4d178135956bf91.zip
Adding upstream version 2.10.36.upstream/2.10.36
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'devel-docs/Makefile.am')
-rw-r--r--devel-docs/Makefile.am62
1 files changed, 62 insertions, 0 deletions
diff --git a/devel-docs/Makefile.am b/devel-docs/Makefile.am
new file mode 100644
index 0000000..117af27
--- /dev/null
+++ b/devel-docs/Makefile.am
@@ -0,0 +1,62 @@
+## Process this file with automake to produce Makefile.in
+
+if ENABLE_GTK_DOC_APP
+app = app
+endif
+
+SUBDIRS = \
+ tools \
+ libgimpbase \
+ libgimpcolor \
+ libgimpconfig \
+ libgimpmath \
+ libgimpmodule \
+ libgimpthumb \
+ libgimpwidgets \
+ libgimp \
+ $(app) \
+ \
+ performance-logs
+
+EXTRA_DIST = \
+ README \
+ README.gtkdoc \
+ contexts.txt \
+ debug-plug-ins.txt \
+ exif-handling.txt \
+ gbr.txt \
+ ggr.txt \
+ gih.txt \
+ gitlab-milestones.txt \
+ gpb.txt \
+ includes.txt \
+ libtool-instructions.txt \
+ parasites.txt \
+ pat.txt \
+ gegl-porting-plan.txt \
+ gtkbuilder-porting-guide.txt \
+ release-howto.txt \
+ structure.xml \
+ submitting-patches.txt \
+ tagging.txt \
+ ui-framework.txt \
+ undo.txt \
+ vbr.txt \
+ xcf.txt
+
+
+# require gtk-doc when making dist
+#
+if ENABLE_GTK_DOC
+dist-check-gtk-doc:
+if ENABLE_GTK_DOC_APP
+ @echo "*** gtk-doc-app must be disabled in order to make dist"
+ @false
+endif
+else
+dist-check-gtk-doc:
+ @echo "*** gtk-doc must be enabled in order to make dist"
+ @false
+endif
+
+dist-hook: dist-check-gtk-doc