summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 09:16:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 09:16:20 +0000
commit76479efc9333353a34df1456748c42f237c28efc (patch)
tree523e902b85a1b6f69170c28a39ef7eb50923524a /debian/rules
parentAdding upstream version 20231210. (diff)
downloadgnome-shell-extensions-extra-76479efc9333353a34df1456748c42f237c28efc.tar.xz
gnome-shell-extensions-extra-76479efc9333353a34df1456748c42f237c28efc.zip
Adding debian version 20231210-1.debian/20231210-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules29
1 files changed, 29 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f3692b0
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,29 @@
+#!/usr/bin/make -f
+
+EXTENSIONS_VERSION = 44
+
+GNOME_SHELL_DEPENDS_LOW = 43
+GNOME_SHELL_DEPENDS_HIGH = 45
+
+%:
+ dh ${@} --no-parallel
+
+execute_after_dh_auto_clean:
+ rm -f extensions/current
+
+ # remove generated files
+ rm -f extensions/44/*/*/schemas/gschemas.compiled
+ rm -f extensions/44/middleclickclose/*/locale/*/LC_MESSAGES/*.mo
+
+execute_before_dh_auto_build:
+ ln -s $(EXTENSIONS_VERSION) extensions/current
+
+execute_after_dh_auto_install:
+ # removing unused files
+ rm -f debian/gnome-shell-extensions-extra/usr/share/doc/*/CHANGELOG.txt
+ rm -f debian/gnome-shell-extensions-extra/usr/share/doc/*/LICENSE.txt
+
+override_dh_gencontrol:
+ dh_gencontrol -- \
+ -Vgnome-shell:Depends:low="$(GNOME_SHELL_DEPENDS_LOW)" \
+ -Vgnome-shell:Depends:high="$(GNOME_SHELL_DEPENDS_HIGH)"