summaryrefslogtreecommitdiffstats
path: root/debian/patches/debian-packaging
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-19 04:38:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-19 04:38:13 +0000
commitf29c37eef239be064a88e5447073dbbc8b82e562 (patch)
tree8f87d81b92143c9f0920e303a2df036f2549079f /debian/patches/debian-packaging
parentReleasing progress-linux version 2.2.43-3~progress7.99u1. (diff)
downloadgnupg2-f29c37eef239be064a88e5447073dbbc8b82e562.tar.xz
gnupg2-f29c37eef239be064a88e5447073dbbc8b82e562.zip
Merging debian version 2.2.43-4.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches/debian-packaging')
-rw-r--r--debian/patches/debian-packaging/Always-build-common-status-codes.h-and-common-audit-event.patch34
-rw-r--r--debian/patches/debian-packaging/Build-regexp-against-debian-s-unicode-data-package.patch39
2 files changed, 73 insertions, 0 deletions
diff --git a/debian/patches/debian-packaging/Always-build-common-status-codes.h-and-common-audit-event.patch b/debian/patches/debian-packaging/Always-build-common-status-codes.h-and-common-audit-event.patch
new file mode 100644
index 0000000..26d4fa9
--- /dev/null
+++ b/debian/patches/debian-packaging/Always-build-common-status-codes.h-and-common-audit-event.patch
@@ -0,0 +1,34 @@
+From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
+Date: Thu, 16 May 2024 17:17:50 -0400
+Subject: Always build common/status-codes.h and common/audit-events.h
+
+This reduces our dependence on files injected into the upstream
+tarball.
+
+This addresses part of #1071202
+
+Forwarded: not-needed
+---
+ common/Makefile.am | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/common/Makefile.am b/common/Makefile.am
+index 65ce35b..3ccc137 100644
+--- a/common/Makefile.am
++++ b/common/Makefile.am
+@@ -140,7 +140,6 @@ endif
+ libgpgrl_a_SOURCES = \
+ gpgrlhelp.c
+
+-if MAINTAINER_MODE
+ # Note: Due to the dependency on Makefile, the file will always be
+ # rebuilt, so we allow this only in maintainer mode.
+
+@@ -159,7 +158,6 @@ status-codes.h: Makefile.am mkstrtable.awk exstatus.awk status.h
+ $(AWK) -f $(srcdir)/exstatus.awk $(srcdir)/status.h \
+ | $(AWK) -f $(srcdir)/mkstrtable.awk -v textidx=3 -v nogettext=1 \
+ -v pkg_namespace=statusstr_ > $(srcdir)/status-codes.h
+-endif
+
+ #
+ # Module tests
diff --git a/debian/patches/debian-packaging/Build-regexp-against-debian-s-unicode-data-package.patch b/debian/patches/debian-packaging/Build-regexp-against-debian-s-unicode-data-package.patch
new file mode 100644
index 0000000..99f93ea
--- /dev/null
+++ b/debian/patches/debian-packaging/Build-regexp-against-debian-s-unicode-data-package.patch
@@ -0,0 +1,39 @@
+From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
+Date: Thu, 16 May 2024 17:02:06 -0400
+Subject: Build regexp against debian's unicode-data package
+
+It should be simple enough to auto-generate the regexp table from
+stock UnicodeData.txt. Upstream doesn't seem inclined to keep it
+up-to-date, and using the stock debian package that ships it instead
+of upstream's stale version will take care of new case sensitivity
+issues automatically.
+
+This also reduces our dependence on material in the upstream tarball
+that differs from what is in upstream revision control.
+
+This addresses one part of #1071202.
+---
+ regexp/Makefile.am | 8 +++-----
+ 1 file changed, 3 insertions(+), 5 deletions(-)
+
+diff --git a/regexp/Makefile.am b/regexp/Makefile.am
+index 307aacf..035858e 100644
+--- a/regexp/Makefile.am
++++ b/regexp/Makefile.am
+@@ -27,13 +27,11 @@ AM_CFLAGS =
+ libregexp_a_SOURCES = jimregexp.h utf8.h jimregexp.c utf8.c
+ libregexp_a_CFLAGS = $(AM_CFLAGS)
+
+-EXTRA_DIST = parse-unidata.awk UnicodeData.txt _unicode_mapping.c
++EXTRA_DIST = parse-unidata.awk _unicode_mapping.c
+
+-if MAINTAINER_MODE
+ BUILT_SOURCES = _unicode_mapping.c
+ MAINTAINERCLEANFILES = _unicode_mapping.c
+
+-_unicode_mapping.c: parse-unidata.awk UnicodeData.txt
++_unicode_mapping.c: parse-unidata.awk
+ $(AWK) $(AWK_HEX_NUMBER_OPTION) -f $(srcdir)/parse-unidata.awk \
+- $(srcdir)/UnicodeData.txt >$@
+-endif
++ /usr/share/unicode/UnicodeData.txt >$@