summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..b9fc7ae
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+
+# no CLI, k8s, require additional dependencies
+export DH_GOLANG_EXCLUDES := go-containerregistry/cmd pkg/authn/k8schain pkg/authn/kubernetes
+
+%:
+ dh $@ --builddirectory=_build --buildsystem=golang --with=golang
+
+override_dh_auto_test:
+# FIXME: investigate build failures in the google package
+ -dh_auto_test