summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/0002-Skip-flaky-TestCrashDumpsAllThreads-on-s390x.patch24
-rw-r--r--debian/patches/series1
3 files changed, 33 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index c6fc1bd..b761a1b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+golang-1.22 (1.22.2-2) unstable; urgency=medium
+
+ * Team upload
+ * Skip flaky TestCrashDumpsAllThreads on s390x (LP: #2061742)
+ https://github.com/golang/go/issues/64650
+
+ -- Shengjing Zhu <zhsj@debian.org> Tue, 16 Apr 2024 16:13:31 +0800
+
golang-1.22 (1.22.2-1~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-updates, remaining changes:
diff --git a/debian/patches/0002-Skip-flaky-TestCrashDumpsAllThreads-on-s390x.patch b/debian/patches/0002-Skip-flaky-TestCrashDumpsAllThreads-on-s390x.patch
new file mode 100644
index 0000000..e94963f
--- /dev/null
+++ b/debian/patches/0002-Skip-flaky-TestCrashDumpsAllThreads-on-s390x.patch
@@ -0,0 +1,24 @@
+From: Shengjing Zhu <zhsj@debian.org>
+Date: Tue, 16 Apr 2024 16:04:03 +0800
+Subject: Skip flaky TestCrashDumpsAllThreads on s390x
+
+Bug: https://github.com/golang/go/issues/64650
+---
+ src/runtime/crash_unix_test.go | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/runtime/crash_unix_test.go b/src/runtime/crash_unix_test.go
+index 20a7ca6..23cc273 100644
+--- a/src/runtime/crash_unix_test.go
++++ b/src/runtime/crash_unix_test.go
+@@ -63,6 +63,10 @@ func TestCrashDumpsAllThreads(t *testing.T) {
+ t.Skipf("skipping; flaky on %s", runtime.GOARCH)
+ }
+
++ if runtime.GOARCH == "s390x" {
++ t.Skipf("skipping; flaky on %s", runtime.GOARCH)
++ }
++
+ switch runtime.GOOS {
+ case "darwin", "dragonfly", "freebsd", "linux", "netbsd", "openbsd", "illumos", "solaris":
+ default:
diff --git a/debian/patches/series b/debian/patches/series
index 4764021..a2455da 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
0001-Skip-flaky-TestCrashDumpsAllThreads-on-mips64le.patch
+0002-Skip-flaky-TestCrashDumpsAllThreads-on-s390x.patch