summaryrefslogtreecommitdiffstats
path: root/agent/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'agent/CMakeLists.txt')
-rw-r--r--agent/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/agent/CMakeLists.txt b/agent/CMakeLists.txt
new file mode 100644
index 0000000..59c1e26
--- /dev/null
+++ b/agent/CMakeLists.txt
@@ -0,0 +1,14 @@
+# Icinga 2 | (c) 2012 Icinga GmbH | GPLv2+
+
+if(MSVC)
+ include_external_msproject(
+ icinga2setupagent
+ ${CMAKE_CURRENT_SOURCE_DIR}/windows-setup-agent/Icinga2SetupAgent.csproj
+ TYPE FAE04EC0-301F-11D3-BF4B-00C04F79EFBC
+ )
+
+ install(
+ FILES ${CMAKE_CURRENT_SOURCE_DIR}/windows-setup-agent/bin/\${CMAKE_INSTALL_CONFIG_NAME}/Icinga2SetupAgent.exe ${CMAKE_CURRENT_SOURCE_DIR}/windows-setup-agent/bin/\${CMAKE_INSTALL_CONFIG_NAME}/Icinga2SetupAgent.exe.config
+ DESTINATION ${CMAKE_INSTALL_SBINDIR}
+ )
+endif()