summaryrefslogtreecommitdiffstats
path: root/lib/mysql_shim/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/mysql_shim/CMakeLists.txt')
-rw-r--r--lib/mysql_shim/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/lib/mysql_shim/CMakeLists.txt b/lib/mysql_shim/CMakeLists.txt
new file mode 100644
index 0000000..fc7dbee
--- /dev/null
+++ b/lib/mysql_shim/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Icinga 2 | (c) 2012 Icinga GmbH | GPLv2+
+
+include_directories(${MYSQL_INCLUDE_DIR})
+
+set(mysql_shim_SOURCES
+ mysql_shim.def
+ mysqlinterface.cpp mysqlinterface.hpp
+)
+
+if(ICINGA2_UNITY_BUILD)
+ mkunity_target(mysql_shim mysql_shim mysql_shim_SOURCES)
+endif()
+
+add_library(mysql_shim SHARED ${mysql_shim_SOURCES})
+
+include(GenerateExportHeader)
+generate_export_header(mysql_shim)
+
+target_link_libraries(mysql_shim ${MYSQL_LIB})
+
+set_target_properties (
+ mysql_shim PROPERTIES
+ FOLDER Lib
+ VERSION ${SPEC_VERSION}
+)
+
+install(
+ TARGETS mysql_shim
+ RUNTIME DESTINATION ${CMAKE_INSTALL_SBINDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_FULL_LIBDIR}/icinga2
+)