summaryrefslogtreecommitdiffstats
path: root/third-party/socketpair/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third-party/socketpair/CMakeLists.txt')
-rw-r--r--third-party/socketpair/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/third-party/socketpair/CMakeLists.txt b/third-party/socketpair/CMakeLists.txt
new file mode 100644
index 0000000..89a38f7
--- /dev/null
+++ b/third-party/socketpair/CMakeLists.txt
@@ -0,0 +1,12 @@
+# Icinga 2 | (c) 2012 Icinga GmbH | GPLv2+
+
+set(socketpair_SOURCES
+ socketpair.c socketpair.h
+)
+
+add_library(socketpair OBJECT ${socketpair_SOURCES})
+
+set_target_properties (
+ socketpair PROPERTIES
+ FOLDER Lib
+)