summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:14:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:14:29 +0000
commit8f1a9a63e6df4574f5b3dee67eb847e36ccb6766 (patch)
tree43428318c9327705aeb581f7d9e1561e383d70a0 /debian/rules
parentAdding upstream version 0.0.1+20160321. (diff)
downloadicingaweb2-module-boxydash-8f1a9a63e6df4574f5b3dee67eb847e36ccb6766.tar.xz
icingaweb2-module-boxydash-8f1a9a63e6df4574f5b3dee67eb847e36ccb6766.zip
Adding debian version 0.0.1+20160321-5.debian/0.0.1+20160321-5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..91efcf5
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+
+MODULE := boxydash
+DEBDIR := debian/icingaweb2-module-$(MODULE)
+
+%:
+ dh ${@}
+
+override_dh_auto_install:
+ mkdir -p $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)
+ find . -maxdepth 1 -mindepth 1 -and -not -name debian -and -not -name ".git*" -and -not -name ".pc" -exec cp -a {} $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) \;
+
+ # move config file
+ mkdir -p $(DEBDIR)/etc/icingaweb2/modules/$(MODULE)
+ cp debian/local/config.ini $(DEBDIR)/etc/icingaweb2/modules/$(MODULE)/
+
+execute_after_dh_installdocs:
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name AUTHORS -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name COPYING -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name LICENSE -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name README -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name "*.md" -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -type d -empty -delete
+ rm -rf $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/doc