summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:26:02 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:26:02 +0000
commitf7323be1d73c99b0094c40ab86cb6da612654712 (patch)
treeb19249cda218754f1137a8ee182bd7d22a16a7ae /debian/rules
parentAdding upstream version 0.10.2+dfsg1. (diff)
downloadicingaweb2-module-pdfexport-f7323be1d73c99b0094c40ab86cb6da612654712.tar.xz
icingaweb2-module-pdfexport-f7323be1d73c99b0094c40ab86cb6da612654712.zip
Adding debian version 0.10.2+dfsg1-3.debian/0.10.2+dfsg1-3
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules32
1 files changed, 32 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..40c46dd
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,32 @@
+#!/usr/bin/make -f
+
+MODULE := pdfexport
+DEBDIR := debian/icingaweb2-module-$(MODULE)
+
+%:
+ dh ${@} --with phpcomposer
+
+override_dh_auto_install:
+ mkdir -p $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)
+ find . -maxdepth 1 -mindepth 1 -and -not -name debian -and -not -name ".git*" -and -not -name ".pc" -exec cp -a {} $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) \;
+
+ # remove useless file
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name \.gitignore -exec rm -f {} \;
+
+ # move config file
+ mkdir -p $(DEBDIR)/etc/icingaweb2/modules/$(MODULE)
+ cp debian/local/config.ini $(DEBDIR)/etc/icingaweb2/modules/$(MODULE)
+
+ # symlink tcpdf to debian package
+ mkdir -p $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/vendor/tecnickcom
+ ln -s /usr/share/php/tcpdf $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/vendor/tecnickcom/tcpdf
+
+execute_after_dh_installdocs:
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name AUTHORS -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name COPYING -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name LICENSE -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name LICENSE.txt -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name README -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name "*.md" -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -type d -empty -delete
+ rm -rf $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/doc