summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/libcroco/csslint/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/libcroco/csslint/CMakeLists.txt')
-rw-r--r--src/3rdparty/libcroco/csslint/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/3rdparty/libcroco/csslint/CMakeLists.txt b/src/3rdparty/libcroco/csslint/CMakeLists.txt
new file mode 100644
index 0000000..8f125c8
--- /dev/null
+++ b/src/3rdparty/libcroco/csslint/CMakeLists.txt
@@ -0,0 +1,16 @@
+set(csslint_EXE csslint)
+
+add_executable(${csslint_EXE} csslint.c)
+
+target_include_directories(${csslint_EXE}
+ PRIVATE
+ ${CMAKE_SOURCE_DIR}/src
+ ${CMAKE_BINARY_DIR}/src
+ ${GLIB_INCLUDE_DIRS}
+ ${LIBXML_INCLUDE_DIRS}
+)
+
+target_link_libraries(${csslint_EXE}
+ PRIVATE
+ croco_LIB
+)