summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/libcroco/docs/reference
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/libcroco/docs/reference')
-rw-r--r--src/3rdparty/libcroco/docs/reference/Makefile.am53
-rw-r--r--src/3rdparty/libcroco/docs/reference/libcroco-docs.sgml39
2 files changed, 92 insertions, 0 deletions
diff --git a/src/3rdparty/libcroco/docs/reference/Makefile.am b/src/3rdparty/libcroco/docs/reference/Makefile.am
new file mode 100644
index 0000000..0ec463d
--- /dev/null
+++ b/src/3rdparty/libcroco/docs/reference/Makefile.am
@@ -0,0 +1,53 @@
+## Process this file with automake to produce Makefile.in
+NULL=
+
+# The name of the module, e.g. 'glib'.
+DOC_MODULE=libcroco
+
+# The top-level SGML file. Change it if you want.
+DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
+
+# The directory containing the source code. Relative to $(srcdir).
+# gtk-doc will search all .c & .h files beneath here for inline comments
+# documenting functions and macros.
+DOC_SOURCE_DIR=../../src
+
+# Extra options to pass to gtkdoc-scanobj or gtkdoc-scangobj.
+SCANGOBJ_OPTIONS=--type-init-func="g_type_init()"
+
+# Extra options to supply to gtkdoc-scan.
+SCAN_OPTIONS=
+
+# Extra options to supply to gtkdoc-mkdb.
+MKDB_OPTIONS=--sgml-mode --output-format=xml
+
+# Extra options to supply to gtkdoc-fixref.
+FIXXREF_OPTIONS=
+
+# Used for dependencies.
+HFILE_GLOB=$(top_srcdir)/src/*.h
+CFILE_GLOB=$(top_srcdir)/src/*.c
+
+# Header files to ignore when scanning.
+IGNORE_HFILES=\
+ $(NULL)
+
+# Images to copy into HTML directory.
+HTML_IMAGES=\
+ $(NULL)
+
+# Extra SGML files that are included by $(DOC_MAIN_SGML_FILE).
+content_files=\
+ $(NULL)
+
+# CFLAGS and LDFLAGS for compiling scan program. Only needed if your app/lib
+# contains GtkObjects/GObjects and you want to document signals and properties.
+GTKDOC_CFLAGS=\
+ $(CROCO_CFLAGS) \
+ $(NULL)
+GTKDOC_LIBS=\
+ $(CROCO_LIBS) \
+ $(NULL)
+
+include $(top_srcdir)/gtk-doc.make
+
diff --git a/src/3rdparty/libcroco/docs/reference/libcroco-docs.sgml b/src/3rdparty/libcroco/docs/reference/libcroco-docs.sgml
new file mode 100644
index 0000000..f67e318
--- /dev/null
+++ b/src/3rdparty/libcroco/docs/reference/libcroco-docs.sgml
@@ -0,0 +1,39 @@
+<?xml version="1.0"?>
+<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"
+ "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd">
+<book id="index" xmlns:xi="http://www.w3.org/2003/XInclude">
+ <bookinfo>
+ <title>Libcroco Reference Manual</title>
+ </bookinfo>
+
+ <chapter>
+ <title>Extensive APIs description</title>
+ <xi:include href="xml/cr-additional-sel.xml"/>
+ <xi:include href="xml/cr-attr-sel.xml"/>
+ <xi:include href="xml/cr-cascade.xml"/>
+ <xi:include href="xml/cr-declaration.xml"/>
+ <xi:include href="xml/cr-doc-handler.xml"/>
+ <xi:include href="xml/cr-enc-handler.xml"/>
+ <xi:include href="xml/cr-fonts.xml"/>
+ <xi:include href="xml/cr-input.xml"/>
+ <xi:include href="xml/cr-num.xml"/>
+ <xi:include href="xml/cr-om-parser.xml"/>
+ <xi:include href="xml/cr-parser.xml"/>
+ <xi:include href="xml/cr-parsing-location.xml"/>
+ <xi:include href="xml/cr-prop-list.xml"/>
+ <xi:include href="xml/cr-pseudo.xml"/>
+ <xi:include href="xml/cr-rgb.xml"/>
+ <xi:include href="xml/cr-sel-eng.xml"/>
+ <xi:include href="xml/cr-selector.xml"/>
+ <xi:include href="xml/cr-simple-sel.xml"/>
+ <xi:include href="xml/cr-statement.xml"/>
+ <xi:include href="xml/cr-string.xml"/>
+ <xi:include href="xml/cr-style.xml"/>
+ <xi:include href="xml/cr-stylesheet.xml"/>
+ <xi:include href="xml/cr-term.xml"/>
+ <xi:include href="xml/cr-tknzr.xml"/>
+ <xi:include href="xml/cr-token.xml"/>
+ <xi:include href="xml/cr-utils.xml"/>
+ <xi:include href="xml/libcroco-config.xml"/>
+ </chapter>
+</book>