summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 19:15:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 19:15:14 +0000
commitbfc3f4fbc9644d12bc57f504d6a906c4072c5f4d (patch)
tree33c71d73689f44be272ac42fba0bfa78d9598d76 /debian/patches
parentAdding upstream version 1.0.3. (diff)
downloadipcalc-ng-bfc3f4fbc9644d12bc57f504d6a906c4072c5f4d.tar.xz
ipcalc-ng-bfc3f4fbc9644d12bc57f504d6a906c4072c5f4d.zip
Adding debian version 1.0.3-1.debian/1.0.3-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/010_new-name-adjustments.patch558
-rw-r--r--debian/patches/020_disable-few-tests.patch57
-rw-r--r--debian/patches/series2
3 files changed, 617 insertions, 0 deletions
diff --git a/debian/patches/010_new-name-adjustments.patch b/debian/patches/010_new-name-adjustments.patch
new file mode 100644
index 0000000..e0fb7c4
--- /dev/null
+++ b/debian/patches/010_new-name-adjustments.patch
@@ -0,0 +1,558 @@
+Description: some adjustments made to change the name to ipcalc-ng
+ The original upstream name is ipcalc, since already there's a debian
+ package with this name we had to rename this one to ipcalc-ng, so
+ some adjustments had to be made to the upstream src and manpage.
+Author: Fabio Augusto De Muzio Tobich <ftobich@debian.org>
+Forwarded: no
+Last-Update: 2023-06-12
+Index: ipcalc-ng/deaggregate.c
+===================================================================
+--- ipcalc-ng.orig/deaggregate.c
++++ ipcalc-ng/deaggregate.c
+@@ -62,7 +62,7 @@ void deaggregate(char *str, unsigned fla
+ if (d1Str == NULL) {
+ if (!beSilent)
+ fprintf(stderr,
+- "ipcalc: bad deaggregation string: %s\n", str);
++ "ipcalc-ng: bad deaggregation string: %s\n", str);
+ exit(1);
+ }
+ d1Str = trim(d1Str);
+@@ -72,7 +72,7 @@ void deaggregate(char *str, unsigned fla
+ if (d2Str == NULL) {
+ if (!beSilent)
+ fprintf(stderr,
+- "ipcalc: bad deaggregation string: %s\n", str);
++ "ipcalc-ng: bad deaggregation string: %s\n", str);
+ exit(1);
+ }
+ d2Str = trim(d2Str);
+@@ -108,14 +108,14 @@ void deaggregate_v4(const char *ip1s, co
+
+ if (inet_pton(AF_INET, ip1s, &ip1) <= 0) {
+ if (!beSilent)
+- fprintf(stderr, "ipcalc: bad IPv4 address: %s\n",
++ fprintf(stderr, "ipcalc-ng: bad IPv4 address: %s\n",
+ ip1s);
+ exit(1);
+ }
+
+ if (inet_pton(AF_INET, ip2s, &ip2) <= 0) {
+ if (!beSilent)
+- fprintf(stderr, "ipcalc: bad IPv4 address: %s\n",
++ fprintf(stderr, "ipcalc-ng: bad IPv4 address: %s\n",
+ ip2s);
+ exit(1);
+ }
+@@ -125,7 +125,7 @@ void deaggregate_v4(const char *ip1s, co
+
+ if (base > end) {
+ if (!beSilent)
+- fprintf(stderr, "ipcalc: bad range\n");
++ fprintf(stderr, "ipcalc-ng: bad range\n");
+ exit(1);
+ }
+
+@@ -183,14 +183,14 @@ void deaggregate_v6(const char *ip1s, co
+
+ if (inet_pton(AF_INET6, ip1s, &ip1) <= 0) {
+ if (!beSilent)
+- fprintf(stderr, "ipcalc: bad IPv6 address: %s\n",
++ fprintf(stderr, "ipcalc-ng: bad IPv6 address: %s\n",
+ ip1s);
+ exit(1);
+ }
+
+ if (inet_pton(AF_INET6, ip2s, &ip2) <= 0) {
+ if (!beSilent)
+- fprintf(stderr, "ipcalc: bad IPv6 address: %s\n",
++ fprintf(stderr, "ipcalc-ng: bad IPv6 address: %s\n",
+ ip2s);
+ exit(1);
+ }
+@@ -200,7 +200,7 @@ void deaggregate_v6(const char *ip1s, co
+
+ if (ipv6_cmp(&base, &end) > 0) {
+ if (!beSilent)
+- fprintf(stderr, "ipcalc: bad IPv6 range\n");
++ fprintf(stderr, "ipcalc-ng: bad IPv6 range\n");
+ exit(1);
+ }
+
+Index: ipcalc-ng/ipcalc-geoip.c
+===================================================================
+--- ipcalc-ng.orig/ipcalc-geoip.c
++++ ipcalc-ng/ipcalc-geoip.c
+@@ -77,7 +77,7 @@ int geo_setup(void)
+
+ ld = dlopen(LIBNAME, RTLD_LAZY);
+ if (ld == NULL) {
+- snprintf(err, sizeof(err), "ipcalc: could not open %s\n", LIBNAME);
++ snprintf(err, sizeof(err), "ipcalc-ng: could not open %s\n", LIBNAME);
+ ret = -1;
+ goto exit;
+ }
+@@ -97,7 +97,7 @@ int geo_setup(void)
+ pGeoIP_delete == NULL || pGeoIP_record_by_ipnum == NULL ||
+ pGeoIP_id_by_ipnum == NULL || pGeoIP_id_by_ipnum_v6 == NULL ||
+ pGeoIP_record_by_ipnum_v6 == NULL) {
+- snprintf(err, sizeof(err), "ipcalc: could not find symbols in libGeoIP\n");
++ snprintf(err, sizeof(err), "ipcalc-ng: could not find symbols in libGeoIP\n");
+ ret = -1;
+ goto exit;
+ }
+Index: ipcalc-ng/ipcalc-maxmind.c
+===================================================================
+--- ipcalc-ng.orig/ipcalc-maxmind.c
++++ ipcalc-ng/ipcalc-maxmind.c
+@@ -77,7 +77,7 @@ int geo_setup(void)
+
+ ld = dlopen(LIBNAME, RTLD_LAZY);
+ if (ld == NULL) {
+- snprintf(err, sizeof(err), "ipcalc: could not open %s\n", LIBNAME);
++ snprintf(err, sizeof(err), "ipcalc-ng: could not open %s\n", LIBNAME);
+ ret = -1;
+ goto exit;
+ }
+@@ -91,7 +91,7 @@ int geo_setup(void)
+ pMMDB_get_value == NULL ||
+ pMMDB_lookup_string == NULL ||
+ pMMDB_open == NULL) {
+- snprintf(err, sizeof(err), "ipcalc: could not find symbols in libmaxmind\n");
++ snprintf(err, sizeof(err), "ipcalc-ng: could not find symbols in libmaxmind\n");
+ ret = -1;
+ goto exit;
+ }
+Index: ipcalc-ng/ipcalc.1.md
+===================================================================
+--- ipcalc-ng.orig/ipcalc.1.md
++++ ipcalc-ng/ipcalc.1.md
+@@ -1,12 +1,12 @@
+-# ipcalc(1) - Perform simple operations on IP addresses and networks
++# ipcalc-ng(1) - Perform simple operations on IP addresses and networks
+
+ ## SYNOPSIS
+-**ipcalc** [OPTION]... <IP address>[/prefix] [netmask]
++**ipcalc-ng** [OPTION]... <IP address>[/prefix] [netmask]
+
+
+ ## Description
+
+-**ipcalc** provides a simple way to calculate IP information for a host
++**ipcalc-ng** provides a simple way to calculate IP information for a host
+ or network. Depending on the options specified, it may be used to provide
+ IP network information in human readable format, in a format suitable for
+ parsing in scripts, generate random private addresses, resolve an IP address,
+@@ -18,7 +18,7 @@ Otherwise the output is JSON formatted w
+ or when specific options are given (e.g., **--prefix**) the output is
+ in the **VAR=VALUE** format.
+
+-The various options specify what information **ipcalc** should display
++The various options specify what information **ipcalc-ng** should display
+ on standard output. Multiple options may be specified. It is required
+ to specify an IP address; several operations require
+ a netmask or a CIDR prefix as well.
+@@ -41,7 +41,7 @@ a netmask or a CIDR prefix as well.
+ Split the provided network using the specified prefix or netmask. That is,
+ split up the network into smaller chunks of a specified prefix. When
+ combined with no-decorate mode (**--no-decorate**), the split networks
+- will be printed in raw form. Example "ipcalc -S 26 192.168.1.0/24".
++ will be printed in raw form. Example "ipcalc-ng -S 26 192.168.1.0/24".
+
+ * **-d**, **--deaggregate**
+ Deaggregates the provided address range. That is, print the networks that
+@@ -138,7 +138,7 @@ a netmask or a CIDR prefix as well.
+
+ ### Display all information of an IPv4
+
+- $ ipcalc --all-info 193.92.150.2/24
++ $ ipcalc-ng --all-info 193.92.150.2/24
+ Address: 193.92.150.2
+ Network: 193.92.150.0/24
+ Netmask: 255.255.255.0 = 24
+@@ -156,7 +156,7 @@ a netmask or a CIDR prefix as well.
+
+ ### Display information in key-value format
+
+- $ ipcalc -pnmb --minaddr --maxaddr --geoinfo --addrspace 193.92.150.2/255.255.255.224
++ $ ipcalc-ng -pnmb --minaddr --maxaddr --geoinfo --addrspace 193.92.150.2/255.255.255.224
+ NETMASK=255.255.255.224
+ PREFIX=27
+ BROADCAST=193.92.150.31
+@@ -168,7 +168,7 @@ a netmask or a CIDR prefix as well.
+
+ ### Display all information of an IPv6
+
+- $ ipcalc --all-info 2a03:2880:20:4f06:face:b00c:0:14/64
++ $ ipcalc-ng --all-info 2a03:2880:20:4f06:face:b00c:0:14/64
+ Full Address: 2a03:2880:0020:4f06:face:b00c:0000:0014
+ Address: 2a03:2880:20:4f06:face:b00c:0:14
+ Full Network: 2a03:2880:0020:4f06:0000:0000:0000:0000/64
+@@ -186,7 +186,7 @@ a netmask or a CIDR prefix as well.
+
+ ### Display JSON output
+
+- $ ipcalc --all-info -j 2a03:2880:20:4f06:face:b00c:0:14/64
++ $ ipcalc-ng --all-info -j 2a03:2880:20:4f06:face:b00c:0:14/64
+ {
+ "FULLADDRESS":"2a03:2880:0020:4f06:face:b00c:0000:0014",
+ "ADDRESS":"2a03:2880:20:4f06:face:b00c:0:14",
+@@ -206,17 +206,17 @@ a netmask or a CIDR prefix as well.
+
+ ### Lookup of a hostname
+
+- $ ipcalc --lookup-host localhost --no-decorate
++ $ ipcalc-ng --lookup-host localhost --no-decorate
+ ::1
+
+ ### IPv4 lookup of a hostname
+
+- $ ipcalc --lookup-host localhost --no-decorate -4
++ $ ipcalc-ng --lookup-host localhost --no-decorate -4
+ 127.0.0.1
+
+ ### Reverse lookup of a hostname
+
+- $ ipcalc -h 127.0.0.1 --no-decorate
++ $ ipcalc-ng -h 127.0.0.1 --no-decorate
+ localhost
+
+ ## Authors
+Index: ipcalc-ng/ipcalc.c
+===================================================================
+--- ipcalc-ng.orig/ipcalc.c
++++ ipcalc-ng/ipcalc.c
+@@ -46,13 +46,13 @@ static unsigned flags = 0;
+ \file ipcalc.c
+ \brief provides utilities for manipulating IP addresses.
+
+- ipcalc provides utilities and a front-end command line interface for
++ ipcalc-ng provides utilities and a front-end command line interface for
+ manipulating IP addresses, and calculating various aspects of an ip
+ address/netmask/network address/prefix/etc.
+
+ Functionality can be accessed from other languages from the library
+- interface, documented here. To use ipcalc from the shell, read the
+- ipcalc(1) manual page.
++ interface, documented here. To use ipcalc-ng from the shell, read the
++ ipcalc-ng(1) manual page.
+
+ When passing parameters to the various functions, take note of whether they
+ take host byte order or network byte order. Most take host byte order, and
+@@ -588,7 +588,7 @@ int get_ipv4_info(const char *ipStr, int
+
+ if (inet_pton(AF_INET, ipStr, &ip) <= 0) {
+ if (!beSilent)
+- fprintf(stderr, "ipcalc: bad IPv4 address: %s\n",
++ fprintf(stderr, "ipcalc-ng: bad IPv4 address: %s\n",
+ ipStr);
+ return -1;
+ }
+@@ -625,14 +625,14 @@ int get_ipv4_info(const char *ipStr, int
+
+ if (prefix > 32) {
+ if (!beSilent)
+- fprintf(stderr, "ipcalc: bad IPv4 prefix %d\n", prefix);
++ fprintf(stderr, "ipcalc-ng: bad IPv4 prefix %d\n", prefix);
+ return -1;
+ }
+
+ if (inet_ntop(AF_INET, &ip, namebuf, sizeof(namebuf)) == 0) {
+ if (!beSilent)
+ fprintf(stderr,
+- "ipcalc: error calculating the IPv4 network\n");
++ "ipcalc-ng: error calculating the IPv4 network\n");
+ return -1;
+ }
+ info->ip = safe_strdup(namebuf);
+@@ -695,7 +695,7 @@ int get_ipv4_info(const char *ipStr, int
+ if (inet_ntop(AF_INET, &maxhost, namebuf, sizeof(namebuf)) == 0) {
+ if (!beSilent)
+ fprintf(stderr,
+- "ipcalc: error calculating the IPv4 network\n");
++ "ipcalc-ng: error calculating the IPv4 network\n");
+ return -1;
+ }
+
+@@ -718,7 +718,7 @@ int get_ipv4_info(const char *ipStr, int
+ if (info->hostname == NULL) {
+ if (!beSilent) {
+ sprintf(errBuf,
+- "ipcalc: cannot find hostname for %s",
++ "ipcalc-ng: cannot find hostname for %s",
+ ipStr);
+ herror(errBuf);
+ }
+@@ -897,7 +897,7 @@ int get_ipv6_info(const char *ipStr, int
+
+ if (inet_pton(AF_INET6, ipStr, &ip6) <= 0) {
+ if (!beSilent)
+- fprintf(stderr, "ipcalc: bad IPv6 address: %s\n",
++ fprintf(stderr, "ipcalc-ng: bad IPv6 address: %s\n",
+ ipStr);
+ return -1;
+ }
+@@ -908,7 +908,7 @@ int get_ipv6_info(const char *ipStr, int
+ if (inet_ntop(AF_INET6, &ip6, errBuf, sizeof(errBuf)) == 0) {
+ if (!beSilent)
+ fprintf(stderr,
+- "ipcalc: error calculating the IPv6 network\n");
++ "ipcalc-ng: error calculating the IPv6 network\n");
+ return -1;
+ }
+
+@@ -916,7 +916,7 @@ int get_ipv6_info(const char *ipStr, int
+
+ if (prefix > 128) {
+ if (!beSilent)
+- fprintf(stderr, "ipcalc: bad IPv6 prefix: %d\n",
++ fprintf(stderr, "ipcalc-ng: bad IPv6 prefix: %d\n",
+ prefix);
+ return -1;
+ } else if (prefix < 0) {
+@@ -928,7 +928,7 @@ int get_ipv6_info(const char *ipStr, int
+ if (ipv6_prefix_to_mask(prefix, &mask) == -1) {
+ if (!beSilent)
+ fprintf(stderr,
+- "ipcalc: error converting IPv6 prefix: %d\n",
++ "ipcalc-ng: error converting IPv6 prefix: %d\n",
+ prefix);
+ return -1;
+ }
+@@ -941,7 +941,7 @@ int get_ipv6_info(const char *ipStr, int
+ if (inet_ntop(AF_INET6, &network, errBuf, sizeof(errBuf)) == 0) {
+ if (!beSilent)
+ fprintf(stderr,
+- "ipcalc: error calculating the IPv6 network\n");
++ "ipcalc-ng: error calculating the IPv6 network\n");
+ return -1;
+ }
+
+@@ -960,7 +960,7 @@ int get_ipv6_info(const char *ipStr, int
+ if (inet_ntop(AF_INET6, &network, errBuf, sizeof(errBuf)) == 0) {
+ if (!beSilent)
+ fprintf(stderr,
+- "ipcalc: error calculating the IPv6 network\n");
++ "ipcalc-ng: error calculating the IPv6 network\n");
+ return -1;
+ }
+
+@@ -983,7 +983,7 @@ int get_ipv6_info(const char *ipStr, int
+ if (info->hostname == NULL) {
+ if (!beSilent) {
+ sprintf(errBuf,
+- "ipcalc: cannot find hostname for %s",
++ "ipcalc-ng: cannot find hostname for %s",
+ ipStr);
+ herror(errBuf);
+ }
+@@ -1131,7 +1131,7 @@ static
+ void usage(unsigned verbose)
+ {
+ if (verbose) {
+- fprintf(stderr, "Usage: ipcalc [OPTION...]\n");
++ fprintf(stderr, "Usage: ipcalc-ng [OPTION...]\n");
+ fprintf(stderr, " -c, --check Validate IP address\n");
+ fprintf(stderr, " -r, --random-private=PREFIX Generate a random private IP network using\n");
+ fprintf(stderr, " the supplied prefix or mask.\n");
+@@ -1175,7 +1175,7 @@ void usage(unsigned verbose)
+ fprintf(stderr, " -?, --help Show this help message\n");
+ fprintf(stderr, " --usage Display brief usage message\n");
+ } else {
+- fprintf(stderr, "Usage: ipcalc [-46sv?] [-c|--check] [-r|--random-private=STRING] [-i|--info]\n");
++ fprintf(stderr, "Usage: ipcalc-ng [-46sv?] [-c|--check] [-r|--random-private=STRING] [-i|--info]\n");
+ fprintf(stderr, " [--all-info] [-4|--ipv4] [-6|--ipv6] [-a|--address] [-b|--broadcast]\n");
+ fprintf(stderr, " [-h|--hostname] [-o|--lookup-host=STRING] [-g|--geoinfo]\n");
+ fprintf(stderr, " [-m|--netmask] [-n|--network] [-p|--prefix] [--minaddr] [--maxaddr]\n");
+@@ -1425,12 +1425,12 @@ dist_printf(unsigned * const jsonfirst,
+
+ /*!
+ \fn main(int argc, const char **argv)
+- \brief wrapper program for ipcalc functions.
++ \brief wrapper program for ipcalc-ng functions.
+
+- This is a wrapper program for the functions that the ipcalc library provides.
++ This is a wrapper program for the functions that the ipcalc-ng library provides.
+ It can be used from shell scripts or directly from the command line.
+
+- For more information, please see the ipcalc(1) man page.
++ For more information, please see the ipcalc-ng(1) man page.
+ */
+ int main(int argc, char **argv)
+ {
+@@ -1565,7 +1565,7 @@ int main(int argc, char **argv)
+ if (ipStr != NULL) {
+ if (!beSilent)
+ fprintf(stderr,
+- "ipcalc: superfluous option given\n");
++ "ipcalc-ng: superfluous option given\n");
+ exit(1);
+ }
+
+@@ -1591,14 +1591,14 @@ int main(int argc, char **argv)
+ if (bit_count(app) > 1) {
+ if (!beSilent)
+ fprintf(stderr,
+- "ipcalc: you cannot mix these options\n");
++ "ipcalc-ng: you cannot mix these options\n");
+ return 1;
+ }
+
+ if ((flags & FLAG_IPV6) && (flags & FLAG_IPV4)) {
+ if (!beSilent)
+ fprintf(stderr,
+- "ipcalc: you cannot specify both IPv4 and IPv6\n");
++ "ipcalc-ng: you cannot specify both IPv4 and IPv6\n");
+ return 1;
+ }
+
+@@ -1613,7 +1613,7 @@ int main(int argc, char **argv)
+
+ switch (app) {
+ case APP_VERSION:
+- printf("ipcalc %s\n", VERSION);
++ printf("ipcalc-ng %s\n", VERSION);
+ return 0;
+ case APP_DEAGGREGATE:
+ deaggregate(ipStr, flags);
+@@ -1631,7 +1631,7 @@ int main(int argc, char **argv)
+ if (ipStr) {
+ if (!beSilent)
+ fprintf(stderr,
+- "ipcalc: provided superfluous parameter '%s'\n", ipStr);
++ "ipcalc-ng: provided superfluous parameter '%s'\n", ipStr);
+ return 1;
+ }
+
+@@ -1639,7 +1639,7 @@ int main(int argc, char **argv)
+ if (prefix < 0) {
+ if (!beSilent)
+ fprintf(stderr,
+- "ipcalc: bad %s prefix: %s\n", (flags&FLAG_IPV6)?"IPv6":"IPv4", randomStr);
++ "ipcalc-ng: bad %s prefix: %s\n", (flags&FLAG_IPV6)?"IPv6":"IPv4", randomStr);
+ return 1;
+ }
+
+@@ -1647,7 +1647,7 @@ int main(int argc, char **argv)
+ if (ipStr == NULL) {
+ if (!beSilent)
+ fprintf(stderr,
+- "ipcalc: cannot generate network with prefix: %u\n",
++ "ipcalc-ng: cannot generate network with prefix: %u\n",
+ prefix);
+ return 1;
+ }
+@@ -1656,7 +1656,7 @@ int main(int argc, char **argv)
+ if (hostname == NULL && ipStr == NULL) {
+ if (!beSilent) {
+ fprintf(stderr,
+- "ipcalc: ip address expected\n");
++ "ipcalc-ng: ip address expected\n");
+ usage(1);
+ }
+ return 1;
+@@ -1674,7 +1674,7 @@ int main(int argc, char **argv)
+ if (ipStr == NULL) {
+ if (!beSilent)
+ fprintf(stderr,
+- "ipcalc: could not resolve %s\n", hostname);
++ "ipcalc-ng: could not resolve %s\n", hostname);
+ return 1;
+ }
+
+@@ -1688,7 +1688,7 @@ int main(int argc, char **argv)
+ prefixStr = chptr;
+ } else {
+ if (!beSilent) {
+- fprintf(stderr, "ipcalc: unexpected argument: %s\n",
++ fprintf(stderr, "ipcalc-ng: unexpected argument: %s\n",
+ chptr);
+ usage(1);
+ }
+@@ -1707,7 +1707,7 @@ int main(int argc, char **argv)
+ if (prefix < 0) {
+ if (!beSilent)
+ fprintf(stderr,
+- "ipcalc: bad %s prefix: %s\n", (flags & FLAG_IPV6)?"IPv6":"IPv4", prefixStr);
++ "ipcalc-ng: bad %s prefix: %s\n", (flags & FLAG_IPV6)?"IPv6":"IPv4", prefixStr);
+ return 1;
+ }
+ }
+@@ -1719,7 +1719,7 @@ int main(int argc, char **argv)
+ if (netmaskStr && prefix >= 0) {
+ if (!beSilent) {
+ fprintf(stderr,
+- "ipcalc: both netmask and prefix specified\n");
++ "ipcalc-ng: both netmask and prefix specified\n");
+ usage(1);
+ }
+ return 1;
+@@ -1731,7 +1731,7 @@ int main(int argc, char **argv)
+ if (prefix < 0) {
+ if (!beSilent)
+ fprintf(stderr,
+- "ipcalc: bad IPv4 prefix: %s\n", prefixStr);
++ "ipcalc-ng: bad IPv4 prefix: %s\n", prefixStr);
+ return 1;
+ }
+ }
+@@ -1748,7 +1748,7 @@ int main(int argc, char **argv)
+ if (splitPrefix < 0) {
+ if (!beSilent)
+ fprintf(stderr,
+- "ipcalc: bad %s prefix: %s\n", (flags & FLAG_IPV6)?"IPv6":"IPv4", splitStr);
++ "ipcalc-ng: bad %s prefix: %s\n", (flags & FLAG_IPV6)?"IPv6":"IPv4", splitStr);
+ return 1;
+ }
+
+Index: ipcalc-ng/netsplit.c
+===================================================================
+--- ipcalc-ng.orig/netsplit.c
++++ ipcalc-ng/netsplit.c
+@@ -67,14 +67,14 @@ void show_split_networks_v4(unsigned spl
+
+ if (inet_pton(AF_INET, info->network, &net) <= 0) {
+ if (!beSilent)
+- fprintf(stderr, "ipcalc: bad IPv4 address: %s\n", info->network);
++ fprintf(stderr, "ipcalc-ng: bad IPv4 address: %s\n", info->network);
+ exit(1);
+ }
+ net.s_addr = ntohl(net.s_addr);
+
+ if (inet_pton(AF_INET, info->broadcast, &broadcast) <= 0) {
+ if (!beSilent)
+- fprintf(stderr, "ipcalc: bad broadcast address: %s\n", info->broadcast);
++ fprintf(stderr, "ipcalc-ng: bad broadcast address: %s\n", info->broadcast);
+ exit(1);
+ }
+ broadcast.s_addr = ntohl(broadcast.s_addr);
+@@ -145,25 +145,25 @@ void show_split_networks_v6(unsigned spl
+
+ if (inet_pton(AF_INET6, info->network, &net) <= 0) {
+ if (!beSilent)
+- fprintf(stderr, "ipcalc: bad IPv6 address: %s\n", info->network);
++ fprintf(stderr, "ipcalc-ng: bad IPv6 address: %s\n", info->network);
+ exit(1);
+ }
+
+ if (inet_pton(AF_INET6, info->hostmax, &netlast) <= 0) {
+ if (!beSilent)
+- fprintf(stderr, "ipcalc: bad IPv6 address: %s\n", info->hostmax);
++ fprintf(stderr, "ipcalc-ng: bad IPv6 address: %s\n", info->hostmax);
+ exit(1);
+ }
+
+ if (inet_pton(AF_INET6, info->netmask, &netmask) <= 0) {
+ if (!beSilent)
+- fprintf(stderr, "ipcalc: bad IPv6 mask: %s\n", info->netmask);
++ fprintf(stderr, "ipcalc-ng: bad IPv6 mask: %s\n", info->netmask);
+ exit(1);
+ }
+
+ if (ipv6_prefix_to_mask(split_prefix, &splitmask) < 0) {
+ if (!beSilent)
+- fprintf(stderr, "ipcalc: IPv6 prefix: %d\n", split_prefix);
++ fprintf(stderr, "ipcalc-ng: IPv6 prefix: %d\n", split_prefix);
+ exit(1);
+ }
+
diff --git a/debian/patches/020_disable-few-tests.patch b/debian/patches/020_disable-few-tests.patch
new file mode 100644
index 0000000..78f280e
--- /dev/null
+++ b/debian/patches/020_disable-few-tests.patch
@@ -0,0 +1,57 @@
+Description: disable two upstream tests
+ Two of the tests provided by upstream is failing when building using
+ cowbuilder, it works on a clean jail and on salsa tests.
+ Not an upstream problem.
+Author: Fabio Augusto De Muzio Tobich <ftobich@debian.org>
+Forwarded: no
+Last-Update: 2023-06-12
+Index: ipcalc-ng/tests/meson.build
+===================================================================
+--- ipcalc-ng.orig/tests/meson.build
++++ ipcalc-ng/tests/meson.build
+@@ -71,14 +71,14 @@ test('RandomIPv6Explicit',
+ ipcalc.full_path() + ' -6 -r 24' + '|grep Address'
+ ]
+ )
+-test('HostnameIPv6Localhost',
+- testrunner,
+- args : [
+- '--test-outfile',
+- ipcalc.full_path() + ' -6 -o localhost',
+- files('hostname-localhost-ipv6')
+- ]
+-)
++#test('HostnameIPv6Localhost',
++# testrunner,
++# args : [
++# '--test-outfile',
++# ipcalc.full_path() + ' -6 -o localhost',
++# files('hostname-localhost-ipv6')
++# ]
++#)
+ test('HostnameIPv4Localhost',
+ testrunner,
+ args : [
+@@ -95,14 +95,14 @@ test('HostnameIPv4LocalhostJson',
+ files('hostname-localhost-ipv4-json')
+ ]
+ )
+-test('IPIPv6Localhost',
+- testrunner,
+- args : [
+- '--test-outfile',
+- ipcalc.full_path() + ' -h ::1',
+- files('ip-localhost-ipv6')
+- ]
+-)
++#test('IPIPv6Localhost',
++# testrunner,
++# args : [
++# '--test-outfile',
++# ipcalc.full_path() + ' -h ::1',
++# files('ip-localhost-ipv6')
++# ]
++#)
+ test('IPIPv4Localhost',
+ testrunner,
+ args : [
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..1843c00
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+010_new-name-adjustments.patch
+020_disable-few-tests.patch