summaryrefslogtreecommitdiffstats
path: root/config.h.in
diff options
context:
space:
mode:
Diffstat (limited to 'config.h.in')
-rw-r--r--config.h.in509
1 files changed, 509 insertions, 0 deletions
diff --git a/config.h.in b/config.h.in
new file mode 100644
index 0000000..267e661
--- /dev/null
+++ b/config.h.in
@@ -0,0 +1,509 @@
+/* config.h.in. Generated from configure.ac by autoheader. */
+
+/* Define if building universal (internal helper macro) */
+#undef AC_APPLE_UNIVERSAL_BUILD
+
+/* Define if debugging info is desired */
+#undef DBG_MJZ
+
+/* Define if default UDP payload length is based on device MTU and socket
+ buffer size */
+#undef DEFAULT_PAYLOAD_LEN_PER_MTU_DISCOVERY
+
+/* AF_PACKET support is available */
+#undef HAVE_AF_PACKET
+
+/* Define to 1 if you have the <arpa/inet.h> header file. */
+#undef HAVE_ARPA_INET_H
+
+/* Define to 1 if you have the `atexit' function. */
+#undef HAVE_ATEXIT
+
+/* Define to 1 if you have the `clock_gettime' function. */
+#undef HAVE_CLOCK_GETTIME
+
+/* Define to 1 if you have the `clock_nanosleep' function. */
+#undef HAVE_CLOCK_NANOSLEEP
+
+/* Define to 1 if you have the declaration of `AF_INET6', and to 0 if you
+ don't. */
+#undef HAVE_DECL_AF_INET6
+
+/* Define to 1 if you have the declaration of `CPU_SET', and to 0 if you
+ don't. */
+#undef HAVE_DECL_CPU_SET
+
+/* Define to 1 if you have the declaration of `ENOBUFS', and to 0 if you
+ don't. */
+#undef HAVE_DECL_ENOBUFS
+
+/* Define to 1 if you have the declaration of `EWOULDBLOCK', and to 0 if you
+ don't. */
+#undef HAVE_DECL_EWOULDBLOCK
+
+/* Define to 1 if you have the declaration of `IFF_TAP', and to 0 if you
+ don't. */
+#undef HAVE_DECL_IFF_TAP
+
+/* Define to 1 if you have the declaration of `IFF_TUN', and to 0 if you
+ don't. */
+#undef HAVE_DECL_IFF_TUN
+
+/* Define to 1 if you have the declaration of `IPV6_ADD_MEMBERSHIP', and to 0
+ if you don't. */
+#undef HAVE_DECL_IPV6_ADD_MEMBERSHIP
+
+/* Define to 1 if you have the declaration of `IPV6_JOIN_GROUP', and to 0 if
+ you don't. */
+#undef HAVE_DECL_IPV6_JOIN_GROUP
+
+/* Define to 1 if you have the declaration of `IPV6_MULTICAST_HOPS', and to 0
+ if you don't. */
+#undef HAVE_DECL_IPV6_MULTICAST_HOPS
+
+/* Define to 1 if you have the declaration of `IPV6_TCLASS', and to 0 if you
+ don't. */
+#undef HAVE_DECL_IPV6_TCLASS
+
+/* Define to 1 if you have the declaration of `IPV6_V6ONLY', and to 0 if you
+ don't. */
+#undef HAVE_DECL_IPV6_V6ONLY
+
+/* Define to 1 if you have the declaration of `IP_ADD_MEMBERSHIP', and to 0 if
+ you don't. */
+#undef HAVE_DECL_IP_ADD_MEMBERSHIP
+
+/* Define to 1 if you have the declaration of `IP_ADD_SOURCE_MEMBERSHIP', and
+ to 0 if you don't. */
+#undef HAVE_DECL_IP_ADD_SOURCE_MEMBERSHIP
+
+/* Define to 1 if you have the declaration of `IP_MULTICAST_ALL', and to 0 if
+ you don't. */
+#undef HAVE_DECL_IP_MULTICAST_ALL
+
+/* Define to 1 if you have the declaration of `IP_TOS', and to 0 if you don't.
+ */
+#undef HAVE_DECL_IP_TOS
+
+/* Define to 1 if you have the declaration of `MCAST_JOIN_GROUP', and to 0 if
+ you don't. */
+#undef HAVE_DECL_MCAST_JOIN_GROUP
+
+/* Define to 1 if you have the declaration of `MCAST_JOIN_SOURCE_GROUP', and
+ to 0 if you don't. */
+#undef HAVE_DECL_MCAST_JOIN_SOURCE_GROUP
+
+/* Define to 1 if you have the declaration of `MSG_DONTWAIT', and to 0 if you
+ don't. */
+#undef HAVE_DECL_MSG_DONTWAIT
+
+/* Define to 1 if you have the declaration of `MSG_PEEK', and to 0 if you
+ don't. */
+#undef HAVE_DECL_MSG_PEEK
+
+/* Define to 1 if you have the declaration of `MSG_WAITALL', and to 0 if you
+ don't. */
+#undef HAVE_DECL_MSG_WAITALL
+
+/* Define to 1 if you have the declaration of `pthread_cancel', and to 0 if
+ you don't. */
+#undef HAVE_DECL_PTHREAD_CANCEL
+
+/* Define to 1 if you have the declaration of `SIGALRM', and to 0 if you
+ don't. */
+#undef HAVE_DECL_SIGALRM
+
+/* Define to 1 if you have the declaration of `SIOCGIFMTU', and to 0 if you
+ don't. */
+#undef HAVE_DECL_SIOCGIFMTU
+
+/* Define to 1 if you have the declaration of `SO_BINDTODEVICE', and to 0 if
+ you don't. */
+#undef HAVE_DECL_SO_BINDTODEVICE
+
+/* Define to 1 if you have the declaration of `SO_DONTROUTE', and to 0 if you
+ don't. */
+#undef HAVE_DECL_SO_DONTROUTE
+
+/* Define to 1 if you have the declaration of `SO_MAX_PACING_RATE', and to 0
+ if you don't. */
+#undef HAVE_DECL_SO_MAX_PACING_RATE
+
+/* Define to 1 if you have the declaration of `SO_REUSEPORT', and to 0 if you
+ don't. */
+#undef HAVE_DECL_SO_REUSEPORT
+
+/* Define to 1 if you have the declaration of `SO_SNDTIMEO', and to 0 if you
+ don't. */
+#undef HAVE_DECL_SO_SNDTIMEO
+
+/* Define to 1 if you have the declaration of `SO_TIMESTAMP', and to 0 if you
+ don't. */
+#undef HAVE_DECL_SO_TIMESTAMP
+
+/* Define to 1 if you have the declaration of `TCP_CONNECTION_INFO', and to 0
+ if you don't. */
+#undef HAVE_DECL_TCP_CONNECTION_INFO
+
+/* Define to 1 if you have the declaration of `TCP_INFO', and to 0 if you
+ don't. */
+#undef HAVE_DECL_TCP_INFO
+
+/* Define to 1 if you have the declaration of `TCP_MAXSEG', and to 0 if you
+ don't. */
+#undef HAVE_DECL_TCP_MAXSEG
+
+/* Define to 1 if you have the declaration of `TCP_NODELAY', and to 0 if you
+ don't. */
+#undef HAVE_DECL_TCP_NODELAY
+
+/* Define to 1 if you have the declaration of `TCP_NOTSENT_LOWAT', and to 0 if
+ you don't. */
+#undef HAVE_DECL_TCP_NOTSENT_LOWAT
+
+/* Define to 1 if you have the declaration of `TCP_QUICKACK', and to 0 if you
+ don't. */
+#undef HAVE_DECL_TCP_QUICKACK
+
+/* Define to 1 if you have the declaration of `TCP_WINDOW_CLAMP', and to 0 if
+ you don't. */
+#undef HAVE_DECL_TCP_WINDOW_CLAMP
+
+/* Define if limiting test traffic to the local-only network (via socket
+ SO_DONTROUTE) should be the default */
+#undef HAVE_DEFAULT_DONTROUTE_ON
+
+/* Define to 1 if you don't have `vprintf' but do have `_doprnt.' */
+#undef HAVE_DOPRNT
+
+/* Define if fast sampling for report intervals is desired */
+#undef HAVE_FASTSAMPLING
+
+/* Define to 1 if you have the `freopen' function. */
+#undef HAVE_FREOPEN
+
+/* Define if syscall(SYS_gettid) available. */
+#undef HAVE_GETTID_SYSCALL
+
+/* Define to 1 if you have the `gettimeofday' function. */
+#undef HAVE_GETTIMEOFDAY
+
+/* Define to 1 if you have the <ifaddrs.h> header file. */
+#undef HAVE_IFADDRS_H
+
+/* Define to 1 if you have the `inet_ntop' function. */
+#undef HAVE_INET_NTOP
+
+/* Define to 1 if you have the `inet_pton' function. */
+#undef HAVE_INET_PTON
+
+/* Define to 1 if the system has the type `int64_t'. */
+#undef HAVE_INT64_T
+
+/* Define to 1 if you have the <inttypes.h> header file. */
+#undef HAVE_INTTYPES_H
+
+/* Define to enable IPv6 support */
+#undef HAVE_IPV6
+
+/* Define to enable IPv6 multicast support */
+#undef HAVE_IPV6_MULTICAST
+
+/* Define if isochronous traffic option is desired and available */
+#undef HAVE_ISOCHRONOUS
+
+/* Define if Kalman tuning is desired and available */
+#undef HAVE_KALMAN
+
+/* Define to 1 if you have the <libintl.h> header file. */
+#undef HAVE_LIBINTL_H
+
+/* Define to 1 if you have the `rt' library (-lrt). */
+#undef HAVE_LIBRT
+
+/* Define to 1 if you have the <linux/filter.h> header file. */
+#undef HAVE_LINUX_FILTER_H
+
+/* Define to 1 if you have the <linux/if_packet.h> header file. */
+#undef HAVE_LINUX_IF_PACKET_H
+
+/* Define to 1 if you have the <linux/if_tun.h> header file. */
+#undef HAVE_LINUX_IF_TUN_H
+
+/* Define to 1 if you have the <linux/ip.h> header file. */
+#undef HAVE_LINUX_IP_H
+
+/* Define to 1 if you have the <linux/sockios.h> header file. */
+#undef HAVE_LINUX_SOCKIOS_H
+
+/* Define to 1 if you have the <linux/udp.h> header file. */
+#undef HAVE_LINUX_UDP_H
+
+/* Define to 1 if you have the <memory.h> header file. */
+#undef HAVE_MEMORY_H
+
+/* Define to 1 if you have the `memset' function. */
+#undef HAVE_MEMSET
+
+/* Define to 1 if you have the `mlockall' function. */
+#undef HAVE_MLOCKALL
+
+/* Define to enable multicast support */
+#undef HAVE_MULTICAST
+
+/* Define to 1 if you have the `nanosleep' function. */
+#undef HAVE_NANOSLEEP
+
+/* Define to 1 if you have the <netdb.h> header file. */
+#undef HAVE_NETDB_H
+
+/* Define to 1 if you have the <netinet/in.h> header file. */
+#undef HAVE_NETINET_IN_H
+
+/* Define to 1 if you have the <netinet/tcp.h> header file. */
+#undef HAVE_NETINET_TCP_H
+
+/* Define to 1 if you have the <net/ethernet.h> header file. */
+#undef HAVE_NET_ETHERNET_H
+
+/* Define to 1 if you have the <net/if.h> header file. */
+#undef HAVE_NET_IF_H
+
+/* Define if packet level debugging is desired */
+#undef HAVE_PACKET_DEBUG
+
+/* */
+#undef HAVE_POSIX_THREAD
+
+/* Define if you have POSIX threads libraries and header files. */
+#undef HAVE_PTHREAD
+
+/* Have PTHREAD_PRIO_INHERIT. */
+#undef HAVE_PTHREAD_PRIO_INHERIT
+
+/* Define if role reversal ids are desired */
+#undef HAVE_ROLE_REVERSAL_ID
+
+/* Define to 1 if you have the `sched_setscheduler' function. */
+#undef HAVE_SCHED_SETSCHEDULER
+
+/* Define to 1 if you have the `sched_yield' function. */
+#undef HAVE_SCHED_YIELD
+
+/* Define to 1 if you have the `select' function. */
+#undef HAVE_SELECT
+
+/* Define if 64 bit sequence numbers are desired and available */
+#undef HAVE_SEQNO64b
+
+/* Define to 1 if you have the `setitimer' function. */
+#undef HAVE_SETITIMER
+
+/* Define to 1 if you have the <signal.h> header file. */
+#undef HAVE_SIGNAL_H
+
+/* Define to 1 if you have the `snprintf' function. */
+#undef HAVE_SNPRINTF
+
+/* Define to 1 if the system has the type `ssize_t'. */
+#undef HAVE_SSIZE_T
+
+/* Define to enable ssm multicast support */
+#undef HAVE_SSM_MULTICAST
+
+/* Define to 1 if stdbool.h conforms to C99. */
+#undef HAVE_STDBOOL_H
+
+/* Define to 1 if you have the <stdint.h> header file. */
+#undef HAVE_STDINT_H
+
+/* Define to 1 if you have the <stdlib.h> header file. */
+#undef HAVE_STDLIB_H
+
+/* Define to 1 if you have the `strchr' function. */
+#undef HAVE_STRCHR
+
+/* Define to 1 if you have the `strerror' function. */
+#undef HAVE_STRERROR
+
+/* Define to 1 if you have the `strftime' function. */
+#undef HAVE_STRFTIME
+
+/* Define to 1 if you have the <strings.h> header file. */
+#undef HAVE_STRINGS_H
+
+/* Define to 1 if you have the <string.h> header file. */
+#undef HAVE_STRING_H
+
+/* Define to 1 if you have the `strtod' function. */
+#undef HAVE_STRTOD
+
+/* Define to 1 if you have the `strtol' function. */
+#undef HAVE_STRTOL
+
+/* Define to 1 if you have the `strtoll' function. */
+#undef HAVE_STRTOLL
+
+/* Define to 1 if the system has the type `struct group_source_req'. */
+#undef HAVE_STRUCT_GROUP_SOURCE_REQ
+
+/* Define to 1 if the system has the type `struct ipv6_mreq'. */
+#undef HAVE_STRUCT_IPV6_MREQ
+
+/* Define to 1 if the system has the type `struct ip_mreq'. */
+#undef HAVE_STRUCT_IP_MREQ
+
+/* Define to 1 if the system has the type `struct ip_mreq_source'. */
+#undef HAVE_STRUCT_IP_MREQ_SOURCE
+
+/* Define to 1 if `imr_multiaddr.s_addr' is a member of `struct
+ ip_mreq_source'. */
+#undef HAVE_STRUCT_IP_MREQ_SOURCE_IMR_MULTIADDR_S_ADDR
+
+/* Define to 1 if the system has the type `struct sockaddr_in6'. */
+#undef HAVE_STRUCT_SOCKADDR_IN6
+
+/* Define to 1 if `sin6_len' is a member of `struct sockaddr_in6'. */
+#undef HAVE_STRUCT_SOCKADDR_IN6_SIN6_LEN
+
+/* Define to 1 if the system has the type `struct sockaddr_storage'. */
+#undef HAVE_STRUCT_SOCKADDR_STORAGE
+
+/* Define to 1 if `tcpi_total_retrans' is a member of `struct tcp_info'. */
+#undef HAVE_STRUCT_TCP_INFO_TCPI_TOTAL_RETRANS
+
+/* Define to 1 if you have the <syslog.h> header file. */
+#undef HAVE_SYSLOG_H
+
+/* Define to 1 if you have the <sys/ioctl.h> header file. */
+#undef HAVE_SYS_IOCTL_H
+
+/* Define to 1 if you have the <sys/select.h> header file. */
+#undef HAVE_SYS_SELECT_H
+
+/* Define to 1 if you have the <sys/socket.h> header file. */
+#undef HAVE_SYS_SOCKET_H
+
+/* Define to 1 if you have the <sys/sockio.h> header file. */
+#undef HAVE_SYS_SOCKIO_H
+
+/* Define to 1 if you have the <sys/stat.h> header file. */
+#undef HAVE_SYS_STAT_H
+
+/* Define to 1 if you have the <sys/time.h> header file. */
+#undef HAVE_SYS_TIME_H
+
+/* Define to 1 if you have the <sys/types.h> header file. */
+#undef HAVE_SYS_TYPES_H
+
+/* Define to enable tcp stats support */
+#undef HAVE_TCP_STATS
+
+/* Define for thread level debugging of the code */
+#undef HAVE_THREAD_DEBUG
+
+/* TUNTAP_TAP support is available */
+#undef HAVE_TUNTAP_TAP
+
+/* TUNTAP_TUN support is available */
+#undef HAVE_TUNTAP_TUN
+
+/* Define to 1 if you have the <unistd.h> header file. */
+#undef HAVE_UNISTD_H
+
+/* Define to 1 if you have the `usleep' function. */
+#undef HAVE_USLEEP
+
+/* Define to 1 if you have the `vprintf' function. */
+#undef HAVE_VPRINTF
+
+/* Define if Web100 is desired and available */
+#undef HAVE_WEB100
+
+/* Define if using WIN32 threads */
+#undef HAVE_WIN32_THREAD
+
+/* Define if winsock2.h exists. */
+#undef HAVE_WINSOCK2_H
+
+/* Define to 1 if the system has the type `_Bool'. */
+#undef HAVE__BOOL
+
+/* Define to disable asserts */
+#undef NDEBUG
+
+/* Name of package */
+#undef PACKAGE
+
+/* Define to the address where bug reports for this package should be sent. */
+#undef PACKAGE_BUGREPORT
+
+/* Define to the full name of this package. */
+#undef PACKAGE_NAME
+
+/* Define to the full name and version of this package. */
+#undef PACKAGE_STRING
+
+/* Define to the one symbol short name of this package. */
+#undef PACKAGE_TARNAME
+
+/* Define to the home page for this package. */
+#undef PACKAGE_URL
+
+/* Define to the version of this package. */
+#undef PACKAGE_VERSION
+
+/* Define to necessary symbol if this constant uses a non-standard name on
+ your system. */
+#undef PTHREAD_CREATE_JOINABLE
+
+/* Define as the return type of signal handlers (`int' or `void'). */
+#undef RETSIGTYPE
+
+/* Define to the type of arg 1 for `select'. */
+#undef SELECT_TYPE_ARG1
+
+/* Define to the type of args 2, 3 and 4 for `select'. */
+#undef SELECT_TYPE_ARG234
+
+/* Define to the type of arg 5 for `select'. */
+#undef SELECT_TYPE_ARG5
+
+/* Define to 1 if you have the ANSI C header files. */
+#undef STDC_HEADERS
+
+/* Define 3rd arg of accept */
+#undef Socklen_t
+
+/* Define to 1 if you can safely include both <sys/time.h> and <time.h>. */
+#undef TIME_WITH_SYS_TIME
+
+/* Define to 1 if your <sys/time.h> declares `struct tm'. */
+#undef TM_IN_SYS_TIME
+
+/* Version number of package */
+#undef VERSION
+
+/* Define WORDS_BIGENDIAN to 1 if your processor stores words with the most
+ significant byte first (like Motorola and SPARC, unlike Intel). */
+#if defined AC_APPLE_UNIVERSAL_BUILD
+# if defined __BIG_ENDIAN__
+# define WORDS_BIGENDIAN 1
+# endif
+#else
+# ifndef WORDS_BIGENDIAN
+# undef WORDS_BIGENDIAN
+# endif
+#endif
+
+/* */
+#undef _REENTRANT
+
+/* Define to empty if `const' does not conform to ANSI C. */
+#undef const
+
+/* Define to `unsigned int' if <sys/types.h> does not define. */
+#undef size_t
+
+/* Define to "int" if <sys/types.h> does not define. */
+#undef ssize_t