summaryrefslogtreecommitdiffstats
path: root/debian/patches/03-sctp.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/03-sctp.patch')
-rw-r--r--debian/patches/03-sctp.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/patches/03-sctp.patch b/debian/patches/03-sctp.patch
new file mode 100644
index 0000000..5aaf5e4
--- /dev/null
+++ b/debian/patches/03-sctp.patch
@@ -0,0 +1,31 @@
+Description: SCTP workaround for kfreebsd
+ Freebsd has SCTP in the kernel but no sctp library is available,
+ then iperf3 fails to compile because the lack of the library.
+ .
+ This patch moves the search for the library before kernel headers checks
+Author: Roberto Lumbreras <rover@debian.org>
+Forwarded: no
+Index: iperf3-3.16/configure.ac
+===================================================================
+--- iperf3-3.16.orig/configure.ac 2024-01-29 09:58:47.796212604 +0100
++++ iperf3-3.16/configure.ac 2024-01-29 09:58:47.792212538 +0100
+@@ -124,9 +124,10 @@
+ # Check for SCTP support
+ if $try_sctp; then
+ AC_CHECK_HEADERS([sys/socket.h])
++AC_SEARCH_LIBS(sctp_bindx, [sctp])
++if test "x$ac_cv_search_sctp_bindx" != "xno"; then
+ AC_CHECK_HEADERS([netinet/sctp.h],
+ AC_DEFINE([HAVE_SCTP_H], [1], [Have SCTP support.])
+- AC_SEARCH_LIBS(sctp_bindx, [sctp])
+ AC_CHECK_TYPES([struct sctp_assoc_value], [], [],
+ [[#include <netinet/sctp.h>]]),
+ [],
+@@ -135,6 +136,7 @@
+ #endif
+ ])
+ fi
++fi
+
+ AC_CHECK_HEADER([endian.h],
+ AC_DEFINE([HAVE_ENDIAN_H], [1], [Define to 1 if you have the <endian.h> header file.]),