summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 03:01:24 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 03:01:24 +0000
commitbbbba88cf6eb914c53ace70a32ed8874d5e600c2 (patch)
tree97210524cb84512c477421e1950f2c6f7e1a3089 /pyproject.toml
parentInitial commit. (diff)
downloadiredis-bbbba88cf6eb914c53ace70a32ed8874d5e600c2.tar.xz
iredis-bbbba88cf6eb914c53ace70a32ed8874d5e600c2.zip
Adding upstream version 1.14.1.upstream/1.14.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml54
1 files changed, 54 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..bc2e5d4
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,54 @@
+[tool.poetry]
+name = "iredis"
+version = "1.14.1"
+description = "Terminal client for Redis with auto-completion and syntax highlighting."
+authors = ["laixintao <laixintao1995@163.com>"]
+readme = 'README.md'
+license = "BSD-3-Clause"
+repository = 'https://github.com/laixintao/iredis'
+homepage = "https://github.com/laixintao/iredis"
+keywords=["Redis", "key-value store", "Commandline tools", "Redis Client"]
+classifiers = [
+# see https://pypi.org/pypi?%3Aaction=list_classifiers
+ "Development Status :: 4 - Beta",
+ "Environment :: Console",
+ "Environment :: Console :: Curses",
+ "Environment :: MacOS X",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
+ # "Programming Language :: Python :: 3.12",
+ "Topic :: Database",
+ "License :: OSI Approved :: MIT License",
+ "Intended Audience :: Developers",
+]
+
+packages = [
+ { include = "iredis" },
+]
+
+[tool.poetry.dependencies]
+python = "^3.8"
+prompt_toolkit = "^3"
+Pygments = "^2"
+mistune = "^3.0"
+configobj = "^5.0"
+click = "^8.0"
+pendulum = "^2.1.0"
+# wcwidth 0.2.x uses pkg_resources which is not supported by PyOxidizer
+wcwidth = "0.1.9"
+packaging = "^23.0"
+redis = "^5.0.0"
+
+[tool.poetry.dev-dependencies]
+pytest = "^7.2"
+pexpect = "^4.7"
+
+[tool.poetry.scripts]
+iredis = 'iredis.entry:main'
+
+[build-system]
+requires = ["poetry-core>=1.0.0"]
+build-backend = "poetry.core.masonry.api"