summaryrefslogtreecommitdiffstats
path: root/irssi-config.h
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:18:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:18:39 +0000
commitfff5217f02d91268ce90c8c05665602c059faaef (patch)
tree2ba24d32dc96eafe7ed0a85269548e76796d849d /irssi-config.h
parentInitial commit. (diff)
downloadirssi-fff5217f02d91268ce90c8c05665602c059faaef.tar.xz
irssi-fff5217f02d91268ce90c8c05665602c059faaef.zip
Adding upstream version 1.4.5.upstream/1.4.5upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'irssi-config.h')
-rw-r--r--irssi-config.h145
1 files changed, 145 insertions, 0 deletions
diff --git a/irssi-config.h b/irssi-config.h
new file mode 100644
index 0000000..39a5abc
--- /dev/null
+++ b/irssi-config.h
@@ -0,0 +1,145 @@
+/* irssi-config.h. Generated from irssi-config.h.in by configure. */
+/* irssi-config.h.in. Generated from configure.ac by autoheader. */
+
+/* Alternate filesystem prefix for Termux */
+#define FHS_PREFIX ""
+
+/* Build with Capsicum support */
+/* #undef HAVE_CAPSICUM */
+
+/* Define to 1 if you have the <dirent.h> header file. */
+#define HAVE_DIRENT_H 1
+
+/* Define to 1 if you have the <dlfcn.h> header file. */
+#define HAVE_DLFCN_H 1
+
+/* */
+#define HAVE_GMODULE 1
+
+/* Define to 1 if you have the <inttypes.h> header file. */
+#define HAVE_INTTYPES_H 1
+
+/* Define to 1 if you have the `otr' library (-lotr). */
+/* #undef HAVE_LIBOTR */
+
+/* Define to 1 if you have the `utf8proc' library (-lutf8proc). */
+#define HAVE_LIBUTF8PROC /**/
+
+/* Build with socks support */
+/* #undef HAVE_SOCKS */
+
+/* misc.. */
+/* #undef HAVE_SOCKS_H */
+
+/* */
+/* #undef HAVE_STATIC_OTR */
+
+/* */
+#define HAVE_STATIC_PERL 1
+
+/* Define to 1 if you have the <stdint.h> header file. */
+#define HAVE_STDINT_H 1
+
+/* Define to 1 if you have the <stdio.h> header file. */
+#define HAVE_STDIO_H 1
+
+/* Define to 1 if you have the <stdlib.h> header file. */
+#define HAVE_STDLIB_H 1
+
+/* Define to 1 if you have the <strings.h> header file. */
+#define HAVE_STRINGS_H 1
+
+/* Define to 1 if you have the <string.h> header file. */
+#define HAVE_STRING_H 1
+
+/* Define to 1 if you have the <sys/ioctl.h> header file. */
+#define HAVE_SYS_IOCTL_H 1
+
+/* Define to 1 if you have the <sys/resource.h> header file. */
+#define HAVE_SYS_RESOURCE_H 1
+
+/* Define to 1 if you have the <sys/socket.h> header file. */
+#define HAVE_SYS_SOCKET_H 1
+
+/* Define to 1 if you have the <sys/stat.h> header file. */
+#define HAVE_SYS_STAT_H 1
+
+/* Define to 1 if you have the <sys/time.h> header file. */
+#define HAVE_SYS_TIME_H 1
+
+/* Define to 1 if you have the <sys/types.h> header file. */
+#define HAVE_SYS_TYPES_H 1
+
+/* Define to 1 if you have the <sys/utsname.h> header file. */
+#define HAVE_SYS_UTSNAME_H 1
+
+/* Define to 1 if you have the `term.h' header. */
+#define HAVE_TERM_H /**/
+
+/* Define to 1 if you have the <unistd.h> header file. */
+#define HAVE_UNISTD_H 1
+
+/* Define to the sub-directory where libtool stores uninstalled libraries. */
+#define LT_OBJDIR ".libs/"
+
+/* Define to the address where bug reports for this package should be sent. */
+#define PACKAGE_BUGREPORT ""
+
+/* Define to the full name of this package. */
+#define PACKAGE_NAME "irssi"
+
+/* Define to the full name and version of this package. */
+#define PACKAGE_STRING "irssi 1.4.5"
+
+/* Define to the one symbol short name of this package. */
+#define PACKAGE_TARNAME "irssi"
+
+/* Define to the home page for this package. */
+#define PACKAGE_URL ""
+
+/* Define to the version of this package. */
+#define PACKAGE_VERSION "1.4.5"
+
+/* printf()-format for uoff_t, eg. "u" or "lu" or "llu" */
+/* #undef PRIuUOFF_T */
+
+/* The size of `int', as computed by sizeof. */
+#define SIZEOF_INT 4
+
+/* The size of `long', as computed by sizeof. */
+#define SIZEOF_LONG 8
+
+/* The size of `long long', as computed by sizeof. */
+#define SIZEOF_LONG_LONG 8
+
+/* The size of `off_t', as computed by sizeof. */
+#define SIZEOF_OFF_T 8
+
+/* Define to 1 if all of the C90 standard headers exist (not just the ones
+ required in a freestanding environment). This macro is provided for
+ backward compatibility; new code need not use it. */
+#define STDC_HEADERS 1
+
+/* true color support in terminal */
+/* #undef TERM_TRUECOLOR */
+
+/* What type should be used for uoff_t */
+/* #undef UOFF_T_INT */
+
+/* */
+/* #undef UOFF_T_LONG */
+
+/* */
+/* #undef UOFF_T_LONG_LONG */
+
+/* use GRegex for regular expressions */
+#define USE_GREGEX /**/
+
+/* Number of bits in a file offset, on hosts where this is settable. */
+/* #undef _FILE_OFFSET_BITS */
+
+/* Define for large files, on AIX-style hosts. */
+/* #undef _LARGE_FILES */
+
+/* Define to 'int' if <sys/socket.h> doesn't define. */
+/* #undef socklen_t */