summaryrefslogtreecommitdiffstats
path: root/src/irc/core/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:18:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:18:39 +0000
commitfff5217f02d91268ce90c8c05665602c059faaef (patch)
tree2ba24d32dc96eafe7ed0a85269548e76796d849d /src/irc/core/Makefile.am
parentInitial commit. (diff)
downloadirssi-upstream.tar.xz
irssi-upstream.zip
Adding upstream version 1.4.5.upstream/1.4.5upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/irc/core/Makefile.am')
-rw-r--r--src/irc/core/Makefile.am62
1 files changed, 62 insertions, 0 deletions
diff --git a/src/irc/core/Makefile.am b/src/irc/core/Makefile.am
new file mode 100644
index 0000000..5881481
--- /dev/null
+++ b/src/irc/core/Makefile.am
@@ -0,0 +1,62 @@
+noinst_LIBRARIES = libirc_core.a
+
+AM_CPPFLAGS = \
+ -I$(top_builddir) \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ $(GLIB_CFLAGS)
+
+libirc_core_a_SOURCES = \
+ bans.c \
+ ctcp.c \
+ channels-query.c \
+ channel-events.c \
+ channel-rejoin.c \
+ irc.c \
+ irc-core.c \
+ irc-channels.c \
+ irc-channels-setup.c \
+ irc-chatnets.c \
+ irc-commands.c \
+ irc-expandos.c \
+ irc-masks.c \
+ irc-nicklist.c \
+ irc-queries.c \
+ irc-servers.c \
+ irc-servers-reconnect.c \
+ irc-servers-setup.c \
+ irc-session.c \
+ irc-cap.c \
+ sasl.c \
+ lag.c \
+ massjoin.c \
+ modes.c \
+ mode-lists.c \
+ netsplit.c \
+ servers-idle.c \
+ servers-redirect.c
+
+pkginc_irc_coredir=$(pkgincludedir)/src/irc/core
+pkginc_irc_core_HEADERS = \
+ bans.h \
+ ctcp.h \
+ channel-events.h \
+ channel-rejoin.h \
+ irc.h \
+ irc-channels.h \
+ irc-chatnets.h \
+ irc-commands.h \
+ irc-masks.h \
+ irc-nicklist.h \
+ irc-queries.h \
+ irc-servers.h \
+ irc-servers-setup.h \
+ irc-cap.h \
+ sasl.h \
+ modes.h \
+ mode-lists.h \
+ module.h \
+ netsplit.h \
+ servers-idle.h \
+ servers-redirect.h
+
+EXTRA_DIST = meson.build