summaryrefslogtreecommitdiffstats
path: root/src/otr/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:18:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:18:39 +0000
commitfff5217f02d91268ce90c8c05665602c059faaef (patch)
tree2ba24d32dc96eafe7ed0a85269548e76796d849d /src/otr/Makefile.am
parentInitial commit. (diff)
downloadirssi-upstream.tar.xz
irssi-upstream.zip
Adding upstream version 1.4.5.upstream/1.4.5upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/otr/Makefile.am')
-rw-r--r--src/otr/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/src/otr/Makefile.am b/src/otr/Makefile.am
new file mode 100644
index 0000000..b9b82d9
--- /dev/null
+++ b/src/otr/Makefile.am
@@ -0,0 +1,40 @@
+moduledir = $(libdir)/irssi/modules
+
+module_LTLIBRARIES = $(otr_module_lib)
+noinst_LTLIBRARIES = $(otr_static_lib)
+
+EXTRA_LTLIBRARIES = \
+ libotr_core.la \
+ libotr_core_static.la
+
+AM_CPPFLAGS = \
+ -I$(top_builddir) \
+ $(GLIB_CFLAGS) \
+ $(OTR_CFLAGS)
+
+libotr_core_la_LDFLAGS = -module -avoid-version -rpath $(moduledir)
+libotr_core_la_LIBADD = $(OTR_LDFLAGS)
+
+otr_sources = \
+ key.c \
+ otr-module.c \
+ otr-formats.c \
+ otr-ops.c \
+ otr-fe.c \
+ otr.c
+
+libotr_core_la_SOURCES = \
+ $(otr_sources)
+
+libotr_core_static_la_SOURCES = \
+ $(otr_sources)
+
+noinst_HEADERS = \
+ irssi-otr.h \
+ key.h \
+ module.h \
+ otr-formats.h \
+ otr-fe.h \
+ otr.h
+
+EXTRA_DIST = meson.build