summaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
new file mode 100644
index 0000000..dee8dc3
--- /dev/null
+++ b/src/meson.build
@@ -0,0 +1,29 @@
+# this file is part of irssi
+
+subdir('lib-config')
+subdir('core')
+foreach s : chat_modules
+ subdir(s)
+endforeach
+subdir('fe-common')
+if have_perl
+ subdir('perl')
+endif
+if have_otr
+ subdir('otr')
+endif
+if want_bot
+ subdir('fe-none')
+endif
+if want_textui
+ subdir('fe-text')
+endif
+if want_fuzzer
+ subdir('fe-fuzz')
+endif
+
+install_headers(
+ files(
+ 'common.h'
+ ),
+ subdir : incdir / 'src')