summaryrefslogtreecommitdiffstats
path: root/tests/fe-text/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/fe-text/Makefile.am')
-rw-r--r--tests/fe-text/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/tests/fe-text/Makefile.am b/tests/fe-text/Makefile.am
new file mode 100644
index 0000000..a0e1d0f
--- /dev/null
+++ b/tests/fe-text/Makefile.am
@@ -0,0 +1,38 @@
+include $(top_srcdir)/utils/glib-tap.mk
+
+PACKAGE_STRING=fe-text
+
+AM_CPPFLAGS = \
+ -I$(top_builddir) \
+ $(GLIB_CFLAGS)
+
+test_programs = test-paste-join-multiline
+
+test_paste_join_multiline_CPPFLAGS = \
+ $(AM_CPPFLAGS)
+
+# test_paste_join_multiline_DEPENDENCIES =
+
+test_paste_join_multiline_LDADD = \
+ ../../src/fe-common/core/libfe_common_core.a \
+ ../../src/core/libcore.a \
+ ../../src/lib-config/libirssi_config.a \
+ @PROG_LIBS@ \
+ @TEXTUI_LIBS@
+
+
+test_paste_join_multiline_SOURCES = \
+ ../../src/fe-text/gui-entry.c \
+ ../../src/fe-text/mainwindows.c \
+ ../../src/fe-text/term-terminfo.c \
+ ../../src/fe-text/terminfo-core.c \
+ ../../src/fe-text/term.c \
+ ../../src/fe-text/textbuffer-formats.c \
+ ../../src/fe-text/textbuffer-view.c \
+ ../../src/fe-text/textbuffer.c \
+ ../../src/fe-text/gui-windows.c \
+ ../../src/fe-text/gui-printtext.c \
+ mock-irssi.c \
+ test-paste-join-multiline.c
+
+EXTRA_DIST += meson.build