summaryrefslogtreecommitdiffstats
path: root/src/bin/netconf/tests/shtests/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 12:15:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 12:15:43 +0000
commitf5f56e1a1c4d9e9496fcb9d81131066a964ccd23 (patch)
tree49e44c6f87febed37efb953ab5485aa49f6481a7 /src/bin/netconf/tests/shtests/Makefile.am
parentInitial commit. (diff)
downloadisc-kea-upstream.tar.xz
isc-kea-upstream.zip
Adding upstream version 2.4.1.upstream/2.4.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/bin/netconf/tests/shtests/Makefile.am')
-rw-r--r--src/bin/netconf/tests/shtests/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/bin/netconf/tests/shtests/Makefile.am b/src/bin/netconf/tests/shtests/Makefile.am
new file mode 100644
index 0000000..718095b
--- /dev/null
+++ b/src/bin/netconf/tests/shtests/Makefile.am
@@ -0,0 +1,19 @@
+SUBDIRS = .
+
+# Shell tests
+SHTESTS = netconf_tests.sh
+
+# As with every file generated by ./configure, clean them up when running
+# "make distclean", but not on "make clean".
+DISTCLEANFILES = $(SHTESTS)
+
+if HAVE_GTEST
+
+# Run shell tests on "make check".
+check_SCRIPTS = $(SHTESTS)
+TESTS = $(SHTESTS)
+
+endif
+
+# Don't install shell tests.
+noinst_SCRIPTS = $(SHTESTS)