summaryrefslogtreecommitdiffstats
path: root/src/lib/exceptions/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 12:15:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 12:15:43 +0000
commitf5f56e1a1c4d9e9496fcb9d81131066a964ccd23 (patch)
tree49e44c6f87febed37efb953ab5485aa49f6481a7 /src/lib/exceptions/Makefile.am
parentInitial commit. (diff)
downloadisc-kea-upstream.tar.xz
isc-kea-upstream.zip
Adding upstream version 2.4.1.upstream/2.4.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/lib/exceptions/Makefile.am')
-rw-r--r--src/lib/exceptions/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/lib/exceptions/Makefile.am b/src/lib/exceptions/Makefile.am
new file mode 100644
index 0000000..a6e7b90
--- /dev/null
+++ b/src/lib/exceptions/Makefile.am
@@ -0,0 +1,16 @@
+SUBDIRS = . tests
+
+AM_CPPFLAGS = -I$(top_srcdir)/src/lib -I$(top_builddir)/src/lib
+AM_CXXFLAGS=$(KEA_CXXFLAGS)
+
+lib_LTLIBRARIES = libkea-exceptions.la
+
+libkea_exceptions_la_SOURCES = exceptions.h exceptions.cc
+libkea_exceptions_la_SOURCES += isc_assert.h
+libkea_exceptions_la_LDFLAGS = -no-undefined -version-info 23:0:0
+
+CLEANFILES = *.gcno *.gcda
+
+libkea_exceptions_includedir = $(pkgincludedir)/exceptions
+libkea_exceptions_include_HEADERS = exceptions.h
+libkea_exceptions_include_HEADERS += isc_assert.h