summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 8 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 6e2b45e..ec21498 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,6 +9,13 @@ include /usr/share/dpkg/pkg-info.mk
# see FEATURE AREAS in dpkg-buildflags(1)
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+# Disable LTO on ppc64el as it causes crashes (LP: #2055151).
+# This has been spotted in Ubuntu, where LTO is enabled by
+# default, but it likely that Debian would be affected too.
+ifeq ($(DEB_HOST_ARCH),ppc64el)
+export DEB_BUILD_MAINT_OPTIONS += optimize=-lto
+endif
+
%:
dh $@ --with python3 -X.la
@@ -22,6 +29,7 @@ override_dh_auto_configure:
--with-pgsql \
--with-boost-libs=-lboost_system \
--enable-generate-docs \
+ --enable-generate-messages \
--enable-shell \
--disable-static \
--disable-rpath \