summaryrefslogtreecommitdiffstats
path: root/src/sed/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:21:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:21:29 +0000
commit29cd838eab01ed7110f3ccb2e8c6a35c8a31dbcc (patch)
tree63ef546b10a81d461e5cf5ed9e98a68cd7dee1aa /src/sed/Makefile.am
parentInitial commit. (diff)
downloadkbuild-29cd838eab01ed7110f3ccb2e8c6a35c8a31dbcc.tar.xz
kbuild-29cd838eab01ed7110f3ccb2e8c6a35c8a31dbcc.zip
Adding upstream version 1:0.1.9998svn3589+dfsg.upstream/1%0.1.9998svn3589+dfsg
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/sed/Makefile.am')
-rw-r--r--src/sed/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/sed/Makefile.am b/src/sed/Makefile.am
new file mode 100644
index 0000000..a6ecc04
--- /dev/null
+++ b/src/sed/Makefile.am
@@ -0,0 +1,42 @@
+## Process this file with automake to produce Makefile.in
+
+# Automake requirements
+AUTOMAKE_OPTIONS = gnits 1.8
+ACLOCAL_AMFLAGS = -I config
+
+PACKAGE = sed
+
+SUBDIRS = intl lib po sed doc testsuite
+
+noinst_DATA = bootstrap.sh
+noinst_HEADERS = basicdefs.h
+
+EXTRA_DIST = BUGS THANKS COPYING.DOC README.boot bootstrap.sh \
+ config/texi2dvi config/help2man
+
+html:
+ cd doc && make html
+
+DISTCHECK_CONFIGURE_FLAGS = XGETTEXT='$(SHELL) -c : dummy' $(EXTRA_DC_FLAGS)
+EXTRA_DC_FLAGS =
+
+full-distcheck:
+ make distcheck EXTRA_DC_FLAGS='--enable-html'
+ make distcheck EXTRA_DC_FLAGS='--disable-i18n'
+ make distcheck EXTRA_DC_FLAGS='--disable-nls'
+ make distcheck EXTRA_DC_FLAGS='--without-included-regex'
+ make distcheck EXTRA_DC_FLAGS='--without-included-gettext'
+
+update-regex:
+ HOST=sources.redhat.com && \
+ BASEURL="http://$$HOST/cgi-bin/cvsweb.cgi/~checkout~/libc/posix" && \
+ QUERY='cvsroot=glibc&content-type=text/plain' && \
+ wget -O lib/regcomp.c "$$BASEURL/regcomp.c?$$QUERY" && \
+ wget -O lib/regexec.c "$$BASEURL/regexec.c?$$QUERY" && \
+ wget -O lib/regex.c "$$BASEURL/regex.c?$$QUERY" && \
+ wget -O lib/regex_.h "$$BASEURL/regex.h?$$QUERY" && \
+ wget -O lib/regex_internal.c "$$BASEURL/regex_internal.c?$$QUERY" && \
+ wget -O lib/regex_internal.h "$$BASEURL/regex_internal.h?$$QUERY" && \
+ wget -O testsuite/BOOST.tests "$$BASEURL/BOOST.tests?$$QUERY" && \
+ wget -O testsuite/PCRE.tests "$$BASEURL/PCRE.tests?$$QUERY" && \
+ wget -O testsuite/SPENCER.tests "$$BASEURL/rxspencer/tests?$$QUERY"