summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog14
-rw-r--r--debian/copyright10
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/string.patch106
4 files changed, 126 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 88593c9..2934899 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,17 @@
+kbuild (1:0.1.9998svn3604+dfsg-1) unstable; urgency=medium
+
+ * Update copyright years
+ * New upstream version 0.1.9998svn3604+dfsg
+
+ -- Gianfranco Costamagna <locutusofborg@debian.org> Thu, 28 Mar 2024 21:22:54 +0100
+
+kbuild (1:0.1.9998svn3589+dfsg-2) unstable; urgency=medium
+
+ * Fix to avoid strings.h usage, prefer string.h instead
+ Closes: #1066204
+
+ -- Gianfranco Costamagna <locutusofborg@debian.org> Thu, 28 Mar 2024 17:06:47 +0100
+
kbuild (1:0.1.9998svn3589+dfsg-1) unstable; urgency=medium
* New upstream version 0.1.9998svn3589+dfsg
diff --git a/debian/copyright b/debian/copyright
index e73ee00..178295b 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -3,19 +3,19 @@ Source: https://svn.netlabs.org/kbuild/
Upstream-Contact: Knut St. Osmundsen <bird-kBuild-spam@anduin.net>
Files: *
-Copyright: 2004-2022 Knut St. Osmundsen <bird-kBuild-spam@anduin.net>
+Copyright: 2004-2024 Knut St. Osmundsen <bird-kBuild-spam@anduin.net>
License: GPL-3+
Files: src/kash/*
src/lib/nt/fts-nt.c
src/lib/nt/fts-nt.h
Copyright: 1990-1994 The Regents of the University of California
- 2016 knut st. osmundsen <bird-klibc-spam-xiv@anduin.net>
+ 2016 Knut St. Osmundsen <bird-klibc-spam-xiv@anduin.net>
License: BSD-3-clause
Files: src/grep/*
Copyright: 1992, 1997-2002, 2004-2012 Free Software Foundation, Inc.
- 2004, Stepan Kasal <kasal@ucw.cz>
+ 2004, Stepan Kasal <kasal@ucw.cz>
2007, Tony Abou-Assaleh <taa@acm.org>
2009-2012, Jim Meyering <jim@meyering.net> and Paolo Bonzini <bonzini@gnu.org>
License: GPL-3+
@@ -30,7 +30,7 @@ License: GPL-2+
Files: src/lib/kDep.*
src/lib/kStuff/*
-Copyright: 2004-2013 knut st. osmundsen <bird-kBuild-spamx@anduin.net>
+Copyright: 2004-2013 Knut St. Osmundsen <bird-kBuild-spamx@anduin.net>
License: Expat
Files: src/lib/console.h
@@ -52,7 +52,7 @@ Copyright:
2010-2014 Felix Geyer <fgeyer@debian.org>
2010-2013 Michael Meskes <meskes@debian.org>
2013-2015 Ritesh Raj Sarraf <rrs@debian.org>
- 2014-2022 Gianfranco Costamagna <locutusofborg@debian.org>
+ 2014-2024 Gianfranco Costamagna <locutusofborg@debian.org>
License: GPL-3+
License: GPL-2+
diff --git a/debian/patches/series b/debian/patches/series
index 6ff8c8e..4fff2e5 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -2,3 +2,4 @@
do-not-build-docs.patch
build-fix
assert.patch
+string.patch
diff --git a/debian/patches/string.patch b/debian/patches/string.patch
new file mode 100644
index 0000000..52887c1
--- /dev/null
+++ b/debian/patches/string.patch
@@ -0,0 +1,106 @@
+Description: Use string.h to fix implicit-function-declaration issues
+Author: Gianfranco Costamagna <locutusofborg@debian.org>
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1066204
+Last-Update: 2024-03-28
+
+--- kbuild-0.1.9998svn3589+dfsg.orig/src/sed/lib/utils.c
++++ kbuild-0.1.9998svn3589+dfsg/src/sed/lib/utils.c
+@@ -27,7 +27,9 @@
+
+ #ifdef HAVE_STRINGS_H
+ # include <strings.h>
+-#else
++#endif /* HAVE_STRING_H */
++
++#ifdef HAVE_STRING_H
+ # include <string.h>
+ #endif /* HAVE_STRINGS_H */
+
+--- kbuild-0.1.9998svn3589+dfsg.orig/src/sed/sed/execute.c
++++ kbuild-0.1.9998svn3589+dfsg/src/sed/sed/execute.c
+@@ -46,9 +46,12 @@ extern int errno;
+
+ #ifdef HAVE_STRINGS_H
+ # include <strings.h>
+-#else
++#endif /* HAVE_STRING_H */
++
++#ifdef HAVE_STRING_H
+ # include <string.h>
+-#endif /*HAVE_STRINGS_H*/
++#endif /* HAVE_STRINGS_H */
++
+ #ifdef HAVE_MEMORY_H
+ # include <memory.h>
+ #endif
+--- kbuild-0.1.9998svn3589+dfsg.orig/src/sed/sed/fmt.c
++++ kbuild-0.1.9998svn3589+dfsg/src/sed/sed/fmt.c
+@@ -23,6 +23,14 @@
+ #include <ctype.h>
+ #include <sys/types.h>
+
++#ifdef HAVE_STRINGS_H
++# include <strings.h>
++#endif /* HAVE_STRING_H */
++
++#ifdef HAVE_STRING_H
++# include <string.h>
++#endif /* HAVE_STRINGS_H */
++
+ #if HAVE_LIMITS_H
+ # include <limits.h>
+ #endif
+--- kbuild-0.1.9998svn3589+dfsg.orig/src/sed/sed/mbcs.c
++++ kbuild-0.1.9998svn3589+dfsg/src/sed/sed/mbcs.c
+@@ -18,6 +18,14 @@
+ #include "sed.h"
+ #include <stdlib.h>
+
++#ifdef HAVE_STRINGS_H
++# include <strings.h>
++#endif /* HAVE_STRING_H */
++
++#ifdef HAVE_STRING_H
++# include <string.h>
++#endif /* HAVE_STRINGS_H */
++
+ int mb_cur_max;
+
+ #ifdef HAVE_MBRTOWC
+--- kbuild-0.1.9998svn3589+dfsg.orig/src/sed/sed/regexp.c
++++ kbuild-0.1.9998svn3589+dfsg/src/sed/sed/regexp.c
+@@ -17,6 +17,14 @@
+
+ #include "sed.h"
+
++#ifdef HAVE_STRINGS_H
++# include <strings.h>
++#endif /* HAVE_STRING_H */
++
++#ifdef HAVE_STRING_H
++# include <string.h>
++#endif /* HAVE_STRINGS_H */
++
+ #include <ctype.h>
+ #include <stdio.h>
+ #ifdef HAVE_STDLIB_H
+--- kbuild-0.1.9998svn3589+dfsg.orig/src/sed/sed/sed.c
++++ kbuild-0.1.9998svn3589+dfsg/src/sed/sed/sed.c
+@@ -24,11 +24,15 @@
+
+
+ #include <stdio.h>
++
+ #ifdef HAVE_STRINGS_H
+ # include <strings.h>
+-#else
++#endif /* HAVE_STRING_H */
++
++#ifdef HAVE_STRING_H
+ # include <string.h>
+-#endif /*HAVE_STRINGS_H*/
++#endif /* HAVE_STRINGS_H */
++
+ #ifdef HAVE_MEMORY_H
+ # include <memory.h>
+ #endif