summaryrefslogtreecommitdiffstats
path: root/kBuild/doc/example1/libhello
diff options
context:
space:
mode:
Diffstat (limited to 'kBuild/doc/example1/libhello')
-rw-r--r--kBuild/doc/example1/libhello/Makefile.kmk30
-rw-r--r--kBuild/doc/example1/libhello/libhello.c24
2 files changed, 54 insertions, 0 deletions
diff --git a/kBuild/doc/example1/libhello/Makefile.kmk b/kBuild/doc/example1/libhello/Makefile.kmk
new file mode 100644
index 0000000..674c8b3
--- /dev/null
+++ b/kBuild/doc/example1/libhello/Makefile.kmk
@@ -0,0 +1,30 @@
+# $Id: Makefile.kmk 2343 2009-04-19 21:44:50Z bird $
+## @file
+# kBuild Example no. 1 - libhello/Makefile.kmk - The libhello sub-makefile.
+#
+
+#
+# The author disclaims copyright to this example script and places
+# it in the public domain.
+#
+# include full-legal-disclaimer.kmk
+#
+
+SUB_DEPTH = ..
+include $(KBUILD_PATH)/subheader.kmk
+
+#
+# The targets.
+#
+LIBRARIES += libhello
+
+#
+# The hello world library.
+#
+libhello_TEMPLATE = ExampleNo1Exe
+libhello_SOURCES = libhello.c
+
+## @todo Create a DLL variant.
+
+include $(FILE_KBUILD_SUB_FOOTER)
+
diff --git a/kBuild/doc/example1/libhello/libhello.c b/kBuild/doc/example1/libhello/libhello.c
new file mode 100644
index 0000000..5a9024d
--- /dev/null
+++ b/kBuild/doc/example1/libhello/libhello.c
@@ -0,0 +1,24 @@
+/* $Id: libhello.c 2343 2009-04-19 21:44:50Z bird $ */
+/** @file
+ * Example no. 1 - libhello.c - Hello world library.
+ */
+
+/*
+ * The author disclaims copyright to this example code and places
+ * it in the public domain.
+ *
+ * #include <full-legal-disclaimer.h>
+ *
+ */
+
+#include <stdio.h>
+
+extern int print_hello_world(void);
+
+int print_hello_world(void)
+{
+ printf("Hello library world!\n");
+ return 0;
+}
+
+