summaryrefslogtreecommitdiffstats
path: root/src/kDepPre/Makefile.kmk
diff options
context:
space:
mode:
Diffstat (limited to 'src/kDepPre/Makefile.kmk')
-rw-r--r--src/kDepPre/Makefile.kmk39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/kDepPre/Makefile.kmk b/src/kDepPre/Makefile.kmk
new file mode 100644
index 0000000..0c76b64
--- /dev/null
+++ b/src/kDepPre/Makefile.kmk
@@ -0,0 +1,39 @@
+# $Id: Makefile.kmk 2886 2016-09-06 14:31:46Z bird $
+## @file
+# Sub-makefile for kDepPre, the precompiler based dependency generator.
+#
+
+#
+# Copyright (c) 2005-2010 knut st. osmundsen <bird-kBuild-spamx@anduin.net>
+#
+# This file is part of kBuild.
+#
+# kBuild is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# kBuild is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with kBuild. If not, see <http://www.gnu.org/licenses/>
+#
+#
+
+SUB_DEPTH = ../..
+include $(KBUILD_PATH)/subheader.kmk
+
+PROGRAMS += kDepPre
+kDepPre_TEMPLATE = BIN
+kDepPre_LIBS = $(LIB_KDEP) $(LIB_KUTIL)
+kDepPre_DEFS.linux = HAVE_FGETC_UNLOCKED=1
+if1of ($(KBUILD_TARGET), win nt)
+kDepPre_DEFS += NEED_ISBLANK=1 __WIN32__=1
+endif
+kDepPre_SOURCES = kDepPre.c
+
+include $(FILE_KBUILD_SUB_FOOTER)
+